Sync Target Upgrade Failed on Joplin 1.0.241

I tried upgrading from v1.0.233 to v1.0.241. When doing that, it prompted me to upgrade sync target as well. I am using Nextcloud on my local network with self signed certificate. And that’s preventing me from upgrading my sync target for the new version.

I have been using 1.0.233 for some time now with the same Nextcloud sync without any issues. I only had to check Ignore TLS certificate errors in the Joplin preferences -> Syncronization -> advanced settings. Not sure why the new version won’t honor this existing setting.

New Joplin Version

Joplin 1.0.241 (prod, darwin)
Revision: 179e3f9 (master)

Old Joplin Version:
Joplin 1.0.233 (prod, darwin)

Operating System

macOS Catalina
Version: 10.15.6 (19G2021)


Joplin upgrade in progress...
Please wait while the sync target is being upgraded. It may take a few seconds or a few minutes depending on the upgrade. The application will automatically restart once it is completed.
The sync target could not be upgraded due to an error. For support, please copy the complete content of this page and paste it in the forum:
The full error was:
request to failed, reason: self signed certificate
FetchError: request to failed, reason: self signed certificate
    at ClientRequest.<anonymous> (/Applications/
    at ClientRequest.emit (events.js:210:5)
    at ClientRequest.EventEmitter.emit (domain.js:476:20)
    at TLSSocket.socketErrorListener (_http_client.js:406:9)
    at TLSSocket.emit (events.js:210:5)
    at TLSSocket.EventEmitter.emit (domain.js:476:20)
    at emitErrorNT (internal/streams/destroy.js:92:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
    at processTicksAndRejections (internal/process/task_queues.js:80:21)
1 Like

Ok I see, the “Ignore TLS errors” setting is setup is a slightly strange way and it means it’s not active when upgrading. I’ll fix it in the next release.

Could you try with v242?

@laurent, thanks for a quick update. It seems to have worked. I clicked on restart and upgrade sync target and it did restart fine. :+1:t2: