Sync problem desktop to mobile phone


I'm new into Joplin and I'm very happy with this App. All ran well since yesterday. Some attachments didn't sync on my mobile phone. All attachments are visible on the Desktop PC (see technical data below). My synchronisation target is OneDrive.

First it got stuck at 3/30 attachments. After uninstalling and reinstalling Joplin on my mobile phone it's now at 3/1670 - so there are NO attachments downloaded now on my mobile phone. Please let me know how to fix that issue. Thank you.

Kind regards
Erich Schmidt


Joplin 2.8.8 (prod, win32)

Client-ID: e2bf8f4dd03341c1aab3757d65234a22
Sync-Version: 3
Profil-Version: 41
Unterstützter Schlüsselbund: Ja

Revision: c2a6a13

Gerätename DESKTOP-K64LIL4
Prozessor Intel(R) Core(TM) i7-6820HQ CPU @ 2.70GHz 2.70 GHz
Installierter RAM 40,0 GB (39,9 GB verwendbar)
Geräte-ID CF53488B-854A-4F1C-AA6A-291BDDD74730
Produkt-ID 00342-50481-08172-AAOEM
Systemtyp 64-Bit-Betriebssystem, x64-basierter Prozessor
Stift- und Toucheingabe Für diese Anzeige ist keine Stift- oder Toucheingabe verfügbar.

Edition Windows 10 Pro
Version 22H2
Installiert am ‎09.‎12.‎2021
Betriebssystembuild 19045.2311
Leistung Windows Feature Experience Pack 120.2212.4190.0


Android 11RP1A.200720.011
Redmi Note 8 Pro
MIUI 12.5.7
Joplin 2.8.1
Database v41


For bug reports, please post them on GitHub - Issues · laurent22/joplin · GitHub
If you are not sure if it's a bug or not, PLEASE POST ON GITHUB ANYWAY.
If you post a bug report here, we cannot track it and there's a chance it won't be looked at and fixed.

For other support queries please indicate:

  • The version you are using. LATEST VERSION is not a version number!
  • If it is a sync issue, please let us know what you are syncing with.
  • If you report a problem with upgrading, please let us know both versions (from/to).
  • If you report a problem with the editor, please tell us which editor you are using (WYSIWYG/Markdown).
  • The operating system you are using.

If you can also please provide a log, as described here: How to enable debugging | Joplin

Posts that do not at least state the version number and operating system will not be answered.

1 Like

I'm having this same exact issue. Desktop (Mac) is syncing fine, but mobile (Android) is getting stuck out of nowhere. I even tried wiping the app, reinstalling and reconnecting via WebDAV, and it gets to 3/50 before it gives a Network Request Failed error, and anything else I've connected to WebDAV loses connectivity as well. All apps are up to date. MacOS is on Ventura, Android OS is on 12. Screenshots and log attached

syncReport-1670087783474.txt (210.8 KB)

1 Like

Hello nikp79,
thank you for your reply and your experience. My problem is solved now! After 2(!) days all the attachments where downloaded on my mobile phone. Interestingly, not one after the other but all at once. I'm happy now because I'm working with a lot of pics and PDF-Files.

Kind regards

Hi @smid,

Just saw this reply! And you didn't do anything differently to make the sync finally work? I have been trying every now and then and still not working as expected. However, I will keep trying. Thanks for letting me know!

Finally tried to sync to mobile this morning after not trying for over a few weeks, and it started working again. didn't do anything different except had added a few more notes and bookmarks via the Desktop app. No idea why the issue in the first place but glad its resolved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.