Sync issue with Nextcloud - Unknown error 2 (403)

I am really digging this! Just one little hiccup that I can hopefully resolve.

I am getting an error when I try to sync with my Nextcloud. I am using Letsencrypt, so not self signed. There error is

Completed: 09/25/2018 11:32 AM

Last error: Error: MKCOL .sync/: Unknown error 2 (403):

On the setting page, here I have no issues connecting:

Success! Synchronisation configuration appears to be correct.

When I run the debug console, it shows nothing at all.  

The log file just spits out the same error:

-09-25 11:03:34: "Error: MKCOL .sync/: Unknown error 2 (403): 
Code: 403
Error: MKCOL .sync/: Unknown error 2 (403): 
    at newError (C:\Users\Matt\AppData\Local\Programs\Joplin\resources\app.asar\lib\WebDavApi.js:284:11)
    at WebDavApi.exec (C:\Users\Matt\AppData\Local\Programs\Joplin\resources\app.asar\lib\WebDavApi.js:313:10)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)

Do any of you geniuses have any idea what I am doing wrong?


Which client and version?
Do you have a debug log?
What is your WebDAV URL? e.g. https://MASK-THIS/remote.php/webdav/Joplin
Did you create the Joplin directory in Nextcloud?
Do you see any errors in the Nextcloud log?

Ahhh, the problem is that I was using /remote.php/dav/ and not webdav. As soon as I put in webdav, it worked perfect on all devices. Thanks!!!

Strange thing. For me /remote.php/dav/files/[USER]/joplin/[DEPARTMENT] is working perfectly.

So what is the difference?

As long as it is a valid webdav endpoint it should work no matter what.

I just guess that the one that didn’t work wasn’t a valid endpoint.

Got a question here! On a device I recived the exact same error as the OP. but in my configuration I have remote.php/webdav, so I removed remote.php but it causes a different error, but I was never using /dav it has always been /webdav so slighty different starting out problem from the OP but the same error. Any ideas how to fix it?


I am now getting the error on the other device too, the same errror, even though they say they are successfully synced, one has all the notes, the other has none, but server has them.

I then performed the version update on the device which has the notes just incase it fixed it but it didn’t. Also deleted, reinstalled and re-configured device that has no notes, didn’t fix it either.

As I was taught (many thanks) in a previous thread (problem unresolved there) on how create a debug log, by creating a flags.txt file. Then inside the app after restart and clicking concole and resyncing nothing appears, just the error on the left below where you click “synchronise”.

The log.txt file is full of content but I dont yet know how to add it to the issue as it says to do in the bug report instructions.

On the mobile debug instructions, I did find a big list of errors and have uploaded 2 them below: (there are 8 pages more of them).