Sync error on Android - Error: Invalid parameters in updateSyncTimeQueries()

Version: Joplin 1.2.6
OS: Android (Samsung Galaxy S9)

I've downloaded an installed Joplin on my Windows 10 laptop, migrated all my contents from evernote to Joplin without any sync issues using Dropbox.

I installed the app on my phone, gave it all permissions but when I try to sync, it gives me the following error: Error: Invalid parameters in updateSyncTimeQueries()

The system time on my laptop and on phone is the same.

I'm attaching a screenshot here for more details

Can someone please help? This is my first time using Joplin and I really want to use this instead of Evernote.

Thanks in advance!

I have the same problem as well, did you solve this?

What version? That should be fixed now.

I haven't been able to solve this, tried multiple times but couldn't figure out the solution. Also, there were no other similar threads here hence I just uninstalled the app and using Evernote for now.

The fix is in v1.3

I see. I am on 1.2.6 android.

I've just updated to 1.3.13 and still got the same issue on my android. I've already tried to clear data and setup the sync again. Do I need to reimport my notes?

An update on this. I can confirm this error message is only showing on my android device. I've set up the sync with another PC without issues. I am using the current latest version (Nov 9th, 2020).

Actually I've just remembered that the root cause of this issue was fixed, which was that certain import Evernote notes could result in invalid data. However, existing invalid data cannot be easily fixed once it has been synced. So your best option is to check the log and find what note ID is having this issue. Then delete the corresponding .md file on the sync target.

But if you, I suggest deleting all the Evernote notes you've imported, and then re-importing them.

Cool! Thanks for your help.

Just another update for those who have the same problem. I never ended up deleting or fixing anything, after creating and modifying a couple of notes for a few hours, the sync started working on Android.

I fixed the problem by reinstalling the application on my Windows laptop and deleting all the old files and uploading all the Evernote enex files again, let it sync for two hours.

Once done, I installed the android app on my phone (version: 1.3.13) and let it sync, this time it didn't give me any error messages. I suspect the earlier issue might have had caused because of a bug in the previous version of the app.

I have the same problem with iPad. Other platforms are fine, but reinstalling will not make it go away. I have not imported any of my notes