Sync does not updated edited resources

  • The version you are using: 2.7.15 (prod, linux)
  • Syncing issue: both ends 2.7.15 (prod, linux)
  • The operating system you are using (linux mint)
  • Sync target=S3 (Amazon).
  • Encryption enabled

Joplin has this great feature where resources embedded in notes are editable, and can be modified while the note is open. Unfortunately, these edits are not syncing between my devices.

Steps to reproduce:

  1. Set up a sync target on two joplin instances on two computers.
  2. Add a resource (text file, image, etc.) to a note.
  3. Click on the resource link to open it in the system default program (or right-click->open to edit an image)
  4. Verify that Joplin has the "file is being watched for edits" banner at the top of the screen
  5. Make some edit to the file in the system-default program (doodle on the image, write foobar in the txt, whatever)
  6. Save the image in the system-default program
  7. Close the system default program
  8. Switch away from the note with the resource and back to it. Verify that the edits are still there.
  9. Sync to another device (ctrl-S on the device with the edited resource, followed by ctrl-S on the other device)
  10. Note that the edits to the resource have not been transferred to the other device.

I have tried a couple permutations too, like editing the markdown of the note that the image is a part of between steps 7 & 8. I see the edits to the markdown edits update, but the resource does not. I also tried restarting the applications, then re-syncing. Regardless, the edits to the resource were only present on the computer they were made on.

How do I resolve this?
Thanks for your help.

Hey there, that's curious
let's start figuring it out by getting the logs first

See how to copy the logs here

Please paste them in a ```codeblock``` like so

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.