Sync between Desktop (Windows) and Mobile (iOS)

Both Apps seem to sync just fine with Nextcloud (obviously same folder... I tried removing the folder and both apps asked me if i wanted to really delete everything/failsafe)
However, none of the notes from the Desktop version appear on iOS and vice versa, database version is v34 on both.... do those not get snyched with eachother? (I noticed a notebook called (Desktop) and the other (Mobile)...)
is this on the roadmap or a known issue?


mhh, ok... I guess its default behavior that the apps dont synchronize with eachother :frowning:
I'll look for an alternative

My sync is working fine on all Apps (Android, iOS, Windows) so this is not a default behavior.

Please add some more information, because with so little information it is impossible to help.

  • Logfile
  • Syncronisation Settings
  • Syncronisation Status (Help->Syncronisation Status)
  • ...
1 Like

I never checked back because originally there was no response, thought this was the default behavior and that clients only sync between their respective platform...
Checked back now to see if things changed but from reading the forums it seems that there are quite a few with these issues...
iOS app (10.7.2 Database v34) says it syncs, so does the desktop app (right now 1.7.11, Profile version 34, sync version 2).
As the nextcloud app seems obsolete I dont synchronize via nextcloud but via webdav (still nextcloud though).
I can see all notes from the iOS app in the nextcloud folder but only sometimes I can see items from the desktop client... I saw one note when I first synced from the desktop client, that note even appeared on the iOS app, i then tried to first modify then delete the note from the ios app but neither change reflected on the desktop app...

  • You have set ignore TLS certificate error, do you have no valid certificate?
    Because the Mobile apps only work with a valid certificate
  • Your sync is not finished (2 of 23)
  • No logs

I do have a valid public certificate from letsencrypt, however if I leave this unchecked I get the error:
request to failed, reason: unable to verify the first certificate (Code UNABLE_TO_VERIFY_LEAF_SIGNATURE)
log.txt (497.6 KB)

Ok you have a valid certificate, but I think not correct configured.
A certificate file should be combination of the server certificate and chained certificates. From the error I think your root certificate or a intermediate certificate is missing.
You can check this with openssl openssl s_client -showcerts -servername <HOST> -connect <HOST>:<PORT>

The ECONNRESET means the other side of the TCP conversation abruptly closed the connection.

2021-03-22 22:04:15: "Sync target info:", "{"version":2}"
2021-03-22 22:04:38: "FetchError: request to failed, reason: read ECONNRESET
FetchError: request to failed, reason: read ECONNRESET
    at ClientRequest.<anonymous> (C:\Program Files\Joplin\resources\app.asar\node_modules\@joplin\lib\node_modules\node-fetch\index.js:133:11)
    at ClientRequest.emit (events.js:310:20)
    at ClientRequest.EventEmitter.emit (domain.js:482:12)
    at TLSSocket.socketErrorListener (_http_client.js:426:9)
    at TLSSocket.emit (events.js:310:20)
    at TLSSocket.EventEmitter.emit (domain.js:482:12)
    at emitErrorNT (internal/streams/destroy.js:92:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
    at processTicksAndRejections (internal/process/task_queues.js:84:21)"

Therefore the syncronization does not work

ok, i used the fullchain certificate now to rule out that error, now i dont need that checkmark anymore but other than that, everything stayed the same it seems...
any indication as to why nextcloud would close this connection to the desktop app but not the ios app?

hmm, seems to me that those errors come from when i switch certificates and restart apache...
its a "lab" server for home use only so i take it down for maintenance frequently and dont expect applications to run during this time...
i actually saw the exact same error on the gui when checking the configuration while i restarted the server but checking again afterwards gives no error...
should i delete the log file, try syncing again and then post the logfile again?

Ok, than when the otherproblem is solved, I think the mobile app syncs than to.


did that, deleted database and log and started anew... checked nextcloud logs also... for some reason joplin kept trying to access nonexisting files
anyhow, after deleting the database, then entering all settings again I had to restart the Joplin app one more time, after that the sync started working

btw, the mobile app always synced, never had an issue

mhh, ok not solved ^^
after a while the same issue re-appears...
deleting the database helps solve it for a while though...
so it at least seems like an issue with joplin sync ^^

I think the best option is to start with a fresh instalation and synctarget.

  1. Export all you notes as JEX
  2. Close Joplin
  3. Delete .config\joplin-desktop
  4. Delete the Appdata on the Mobile device
  5. Delete all folders/files in your Nextcloud WebDAV Jolin folder
  6. Start Joplin
  7. Import the JEX file
  8. Setup Sync on you PC
  9. Wait untill all Data are synced
  10. Setup Sync on Mobile device

Importend, make sure you have alle you data exported, otherwise data loss may occur!

1 Like

I dont actually have any "production" notes yet so i wont need to export/restore...
I did start "fresh", deleting the whole Joplin folder on nextcloud before installing the desktop/ios app again (3days ago when i posted here).
Should I do this again? what appdata on mobile device do you mean to delete? the whole app?
sync on mobile devices works fine by the way.