Status of JoplinPortable?

Last year I tried Joplin Portable and ran into issues, it seems that it was not truly portable, it was writing to my Windows C: drive. I was not able to run JoplinPortable from a stick installation, and Joplin from a C: drive installation independently. Have these problems been fixed?

My end goal is to run JoplinPortable against a file repository on the same stick.


It was working last year and still working this year, but you probably ran into some issue. In general you need to make sure only one instance of Joplin is running at a time, so if you have any installed one, you should close it before running the portable one.

The issue was that I launched JoplinPortable from a USB stick that was in a machine that already had Joplin installed on it (I wanted two separate data sources). When I launched JoplinPortable, it started recognizing the local installation of Joplin on C: drive.

Is JoplinPortable on a different release schedule than Joplin Desktop?

1 Like

No, the portable and regular apps are released at the same. They are pretty much the same app anyway except for some internal flags that are on for the portable app.

From what you're saying it sounds like you already had the regular app running on the computer, so when you've started the portable app, it didn't actually start it but instead brought the regular app to the front. So you need to close it completely first by right clicking on the tray icon and selecting "Close".

I can only suggest you try again as it should work.

I concur, Joplin Portable is ALL that I use, on 4 PCs and a few USB drives.

Either Windows is writing something itself like to the swap, or perhaps you had or have the Joplin FULL already setup and the portable perhaps was using the default FULL's database? Could that be possible?

For all mine the Joplin notes DB and sundry files are ALL located under the Joplin Portable folder itself.

Same here for work I only use JoplinPortable. For my personal computer installed the full version but other than automatic updates there are not benefits so most probably will move to portable version

When I run version 1.2.6 on my USB stick, Task Manager says that some of the Joplin tasks are working with files under C:...\apps.
I upgraded to JoplinPortable 2.1.7, and now Task Manager shows only one thread working against a file on the USB stick.
I still have some testing to go through but it looks like that problem is gone. Thanks!

I believe when Joplin portable starts it unpacks some libs somewhere in your app data folders before it can start.

I did notice that some Joplin threads opened to C:...\temp\ files when it was running in the SysTray. When I turned off that systray icon from inside Joplin, those go away.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.