Don't use JoplinPortable, it's not independent from installed Joplin

I have Joplin 1.2.6 running under Windows 10, synching with DropBox. I wanted to test JoplinPortable.exe on a USB stick plugged into the same machine. I dropped the exe into a newly created dir on the stick. When I ran the app, it did create a sibling dir JoplinProfile where it creates SQLite files. I provided access to DropBox and JoplinPortable started synching right away, using the configuration data from the non-USB-stick. OK so that messed up, I unplug the stick and now the C: drive installed version of Joplin duplicates the errors seen running JoplinPortable.
It doesn't appear to be a truly portable app, on my first test. Don't use it.



Thanks for this. Months ago I too ran into a similar situation. My solution was to switch to Joplin Portable totally, for all my PCs. I got the issues ironed out, well, I actually started over and reimported my Evernote notes again. Then setup my sync and it's worked fine ever since. I've not had any issues with it since then.

I use Joplin Portable on 3 Win 10 PCs and 2 Android and have copies of it on several USB sticks. All the USB versions are simply copies of my 'master' stick and all work perfect.

One thing I've learned, do a weekly export of your notes to a JEX file. I do this then use 7Zip to make an encrypted 7z of the JEX file and place it on my Cloud drive. If I am thinking correctly the JEX is not encrypted., an encrypted 7z file keeps it from being read by anyone else. That way I have a good recent copy of all my notes in case it hits the fan again.


This issue came out of synchronization issues also. I wanted to make sure that I always have a system working to fall back on, that's why I started playing with JoplinPortable. I make daily backups yielding a 330MB JEX file.

More information on this issue: I used Windows Apps facility to uninstall Joplin.exe from my computer (not the USB stick). After the uninstall, I reinstalled Joplin.exe (v1.2.6), and got a warning that Joplin was still running, please close it. I opened Windows process explorer and found an idle thread named Joplin that was doing nothing but using 20% CPU. Killed it, reinstalled, then everything was working fine.

Which brings up these new issues:
(1) Joplin did not shut down correctly (it seems I can have up to 4 Joplin threads running and not all of them made an exit).
(2) Joplin uninstall did not completely uninstall all the sqlite files, because after a reinstall, there was no resynch needed. Where are the sqlite files installed and why are they not removed during an install?

I still want the JoplinPortable.exe to run off my USB stick, I'll just set it up on a non-Joplin machine at first.