Spell checker works in note title but not note body

Hi, I use Joplin extensively across a number of machines for business and personal use.

I have an issue on all machines where the spell checker feature works fine in note titles, but does not activate at all in the note body. This is consistent across all machines.

Is this by design, an option I need to enable or a bug? Is it an issue unique to Arch + Plasma?

This issue has been consistent since the spell checker was first implemented and I have never been able to get the spell checker working on any of my machines.

This has perplexed me for a while and I would very much appreciate any help, even if it is to understand this feature is not available to me for some reason.

Thanks to all the Joplin contributors.


All machines (3 x desktops, 4 laptops) use the latest appimage (currently Joplin 2.7.15 on this machine), Arch Linux (current kernel 5.17.4-arch1-1 on this machine) & KDE Plasma (X11, currently Plasma 5.24.4 on this machine). Issue has persisted across many. many versions of Arch & Plasma. architecture of machines is diverse (AMD, Intel, old, new, etc.)

Can't really help there...I assume, the spellchecker is correctly activated in the settings as well as on the spellchecker icon and a language is selected, right?

Yes, to all three assumptions.

I have realised the spell checker works in the Rich Text editor, but not in the mark-down editor (which is the one I use). So perhaps it is by design and everything is fine?

Thanks for the consideration ...

It's not exactly by design, but it's a limitation of the markdown editor Joplin uses.

I described how you can get spellchecking support here but fair warning, it has it's drawbacks.

This is something that will be improved in the future.


Ah, I'll file it as solved under "problem user" then, I should have realised.

Thanks for letting me know and for the link, much appreciated.

Yes,it will be a nice upgrade when the feature is stable.

Thanks again!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.