Spanish Accents in MacOS Paste Last Listed Item


This bug is currently hard to reproduce, but it has been an issue for long enough that I wanted to post this anyway. It's likely someone else has had it and they could help me establish how to consistently reproduce it.

The issue is basically that I'm typing away in Spanish (with plenty of accents like the second a in "ojalá" or with n's with a special character as in "niño") and then suddenly, at some point in my writing, typing an accent or a " ˜ " (the special character in "niño") will paste, immediately after the special character, a bunch text. The pasted text is extracted somehow from the very last listed (numbered or not, as in typing " 1. " or " - ") item I have typed out before typing the troublesome special accent. The last listed Item I typed out may very well be from another markdown document.

For example, if I have a large document with hundreds of numbered items (having written a numbered list that goes from 1 to 3, and then another one that goes from 1 to 5, and another one that goes from 1 to 2, etc.), and then create a new blank document, after I satisfy the (still unclear) conditions under which the troublesome accents appear in the new document, the pasted text could be the very last number from the other, larger document. However, if I've written listed items immediately before the troublesome accent, the pasted text will likely be from the very same document.

Here are some issues that may help narrow down what's happening:

  • If I'm fast enough when I type, I can actually squeeze in a letter after the accent, before the pasted text appears.
  • This bug seems to require you to have written quite a bit of text before typing a troublesome special accent. This means that typing accented letters in a blank document will not give you this bug, which is part of the issue regarding reliable reproducibility of the bug.
  • A quick and dirty way of fixing this issue is cutting and pasting the whole document. After you do that, even if you type the same accents that previously were troublesome, the pasted text will not appear. This is also why I'm not including sample text, since copying and pasting it will not yield the reproducible bug.
  • If I edit in an external editor, like TextMate or Text Edit, the bug never appears.

I'm using Joplin version for Mac (Big Sur 11.1). I exclusively use the Markdown editor. I have an American keyboard, so typing in an accent goes like alt-option + e to prompt the text editor to add an accent to whichever next vowel I choose, and then a vowel (e.g. a). Adding an " ñ " is similar: alt-option + n to prompt the text editor and then n again.

I'm sorry if this doesn't give enough information to reliably reproduce the error. As I mentioned before, I've been dealing with this issue for months, and I figured posting this with what I know meant higher chances of solving the issue than not. As soon as I figure out ways of reliably reproducing the error (or other quirks that may help understand what's happening) I will come back and edit this.

Thanks for your time reading and helping me out!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.