Homepage    |    Wiki    |    GitHub    |    Twitter

Some notes just... disappeared

Hi There,

I've recently noticed some of my notes just gone, or old content, after closing and restaring Joplin. This is a local issue. I share my notes between my devices using NextCloud. Synchronisation works fine, no errors.

Joplin 2.6.10 (prod, linux)
Client ID: c1c5fb03060e482d825a3fa8a828c8ff
Sync Version: 3
Profile Version: 41
Keychain Supported: No
Revision: 98fba37

I also have an Android version of Joplin: 2.6.8 (Android 11)

-- Context / What happened:
The Desktop version showed 'suddenly' some notes in previous version (I mean, their content did not match the finaltext modified a couple of days ago) and some others were simply missing (example: 1 noteboork was containing 14 notes, and now it has only 11). Eech time, there ia a Sync, there is no error.
I imagined it was a local (database) issue in Linux, because the Android version shows all notes, as final.
So, I chose to run from options the 'Delete the local data and re-download from sync target'. After Desktop app restated, all notes were there, complete in their entirely. The Android version didn't show any change. Now both showed the same notes.
I was a happy camper until I closed Joplin Desktop app and a couple of hours hours I restarted the Desktop version and... bang! some notes are now missing. The Android version still doesn't show any change.

What the heck is happening, and is there a way to dal with that really annoying issue, I'm really scared to loose some notes as I worked a lot on them.

Thanks in advance for your help!
58

I have never experienced anything similar.

Are you using any plugins? What happens, if you start Joplin in safe mode? I only ever heard of notes vanishing was when people were messing around with the sync target.

What I don't understand is that your notes are still around on Android, which makes no sense because Joplin does a 2-way sync, so if notes are gone/deleted on the desktop app, that delete operation is synced to the sync target and then synced to Android, which means the note(s) will be removed from the Android device.

Thanks tessus for taking care of my issue.

The only plugin in use in Joplin is Simple Backup v1.0.5. When this issue occured teh first time I have dicided to switch it off. I trestored the notes and they disappered agin and the plugin was still deactivated.

I just tried in safe mode and the notes are still missing.

to illustarte my issue, I just show you my notes with screenshots I took few minutes ago, Joplin Desktop app and Android app:


Is that possible the database in Linux is corrupted and the synch does not really grab the notes from NextCloud storage?

In any case, that's weird and I'd like to understand what to do to fix that (I thought of removing totally Joplin from Linux, rinstall it and load a JEX file with my notes, I'm just worried if something goes wrong, I'll loose some notes).

I still don't understand what is going on. e.g. what is this [object Object] error on Android? The notes appear to be available and the disappear. I don't get it.

Is this reproducible? If yes, please collect logs (on Desktop and Android) and open an issue on gh.

Hello,

Yes, I confirm the issue is reproductible. in The Desktop app, no errors in the logs or cnsole. The Console shows some warning though. Some errors in the Android app logs. I'm in the process of opening an issueon GitHub.

Thanks
58

1 Like