Slowness and sometimes “the window is not responding” error message


My problem is practically solved with version 3.0.6 which includes, among other things:
Improved: Refactor sidebar to better handle thousands of tags and notebooks (#10331) (#4251 by @personalizedrefrigerator)

A huge thank you :slight_smile:

Yesterday, before installing this version, my first sync was still not completed. I was still at the Download stage, i.e. 13 days after the start of sync!

I then installed 3.0.6. The sync was still in progress but around 10 times faster:


and above all: I could use Joplin during sync, which was impossible before!

On the other hand, I sometimes had a little lag, note changes and/or my cursor went back to the top of a note :thinking:, but much less than before, and maybe that it is only during the first sync and/or that's another problem, to see over time...

4 hours after installing 3.0.6, the sync finished:

I manually clicked sync and a few seconds later it finished, indicating that the first full sync was finally completed.

I was curious to see if the "small" synchros which are launched automatically when you modify notes, were going to make Joplin lag as was previously the case: practically not: Joplin remains usable and the small sync only lasts a few seconds.

In my impulse I launched a manual backup because it also made Joplin unusable: damn, I had big lags, and the message The window does not respond twice but a few tens of seconds later, it works: Joplin is usable while the backup is in progress.
In any case, I will continue to do as planned: make manual backups when I don't use Joplin.

In the end, I am very happy, and thank you very much for this update :slight_smile: