Shortcut for transpose characters (swapping characters)

I am very happy with Joplin! I have abandoned Evernote and I am writing all my notes now in Joplin. I am skilled in 10-finger typing but often I transpose two characters like Jolpin instead of Joplin.

As a Mac user, I am used to the shortcut CTRL-T for "Swap the character behind the insertion point with the character in front of the insertion point." (see Mac keyboard shortcuts.

I wonder if it would possible to add this shortcut to Joplin? I am not only genuinely missing it but I am so accustomed to it from other software that I always try to use it automatically in Joplin as well.

Hi @petzi53
on my Mac, under Yosemite, the shortcut ctrl+t works fine in Joplin 2.4.12.

Hi @betternote,

Thanks for your comment! I am working with macOS Monterey 12.3 and Joplin 2.7.15 (prod, darwin), but the transpose shortcut does not work for me.

I also looked under keyboard shortcuts and could not find this shortcut. Could you tell me the name of this shortcut in your list of keyboard shortcuts? (Under "Preferences" -> "Keyboard Shortcuts"). Perhaps it is a regression or just missing in my list of shortcuts…

Hi @petzi53,
I didn't know it until I read your question and tested it to see if it worked on my Mac.
The most surprising thing is that it is not listed in the System Preferences, like the many shortcuts found on the Apple help page you mentioned.
Most likely, it could be a regression.

Hi @betternote

With "Preferences" -> "Keyboard Shortcuts," I didn't mean the Apple System Preferences, but I referred to the Joplin Preferences (under the menu "Joplin"). There is a table of all available shortcuts for Joplin. I would like to know if the shortcut CTRL-T is in your table of Joplin preferences and if this is the case, what is the name of the command (first column in the table)?

Sorry for the misunderstanding.
I don't find this shortcut in the Joplin preferences.
Luckily, it's a MacOS shortcut that still works on mine.

Luckily, it's a macOS shortcut that still works on mine.

These are my worries: The shortcut CTRL-T works for me on finder and many other apps. But not in Joplin. After your messages, I wonder what could be the reason for different shortcut behavior? Thank you anyway for giving me clues to my question.

It's incomprehensible, I just discovered that my test is only valid on the title! When the cursor is in the body of the note, nothing works anymore.
This explains why I don't have the spell check outside the title.
Apparently, only the title area is accessible to the MacOS functions.
@Laurent, does this mean anything to you?

I just noticed that the shortcut CTRL-T for transpose characters is working now! I do not know what happened. I couldn't find any notice about this improvement in the changelogs. Anyway, I will close this thread by choosing this note as the solution.