Scratchpad for MacOS system tray

I was wondering if it is possible to create a widget for the system tray of MacOS to use as a scratchpad and take quick notes.

And, I created a demo: GitHub - uroybd/JoplinScratchPad: A Scratchpad for Joplin and MacOS and Linux

It is currently using the Data API.

The actual tray widget is pretty simple. So, I was wondering if it can be integrated directly into Joplin. That's why I tried to do this in React and Electron although none of them are on my stack.

If you don't want to integrate it, well, I'll polish this and create a standalone side-car sort of app since it will be very much handy for me.


@laurent awaiting your decision, whenever you are free.

Does this work on all platforms or only macOS? I think for inclusion the same functionality needs to be available on all three supported OSs for desktop.

It is MacOS only. Similar things can be done in some linux desktop. Not sure about Windows though.

Actually I saw similar apps for note-taking in mac. But I wanted it to be integrated with Joplin so I worked on it.

I do understand however an OS-specific feature could be a thing to be ignored. But with a small piece of code we can provide greater ergonomic. That is something we can think about.

I think this app would be great and I'm actually missing this functionality on MacOS quite a bit.

Similar features have been requested in the past but due to OS-specific needs and limitations have never been implemented. So I really don't see this making its way into the main app.

However, I think a third party app would still benefit many MacOS users. So if you're willing to maintain your project and provide binaries for it that would be amazing.

I'm already working on that. An electron and Vue version for now. Eventually, a Swift version (I have to learn it).

I'll post the updates here.

1 Like

I've released a version of this app.

Bug reports and PRs are welcome!


Thanks for sharing this. For the arm64 version isn't working. It says the app is damaged and cannot be opened. The other version works with Rosetta. Great stuff. I really like it and I think I'm gonna use it in the future.

Two suggestions:

  1. It would be nice to have some GUI element to start a new note. As of now it seems like you have to close the app in order to start with a fresh note.
  2. Keyboard shortcut to toggle the note popup.
1 Like

I thought about a new note too. Also renaming once synced with joplin. And instead of restoring the last one from that notebook create a new one if that last one is not of today.

Will implement them soon.

Have to check the thing about arm64. I'm also in arm64.

Released v1.1.0


  • New Note button
  • Sync progress button
  • File name and rename option


  • Tray Icon
  • App Name
  • Fix: not showing note pane on startup.
  • New scratchpad resolution. i.e. Create a new note for a new day.

Released v1.1.1 with some fixes.


  • Notebook list refresh action


  • Fix: Fixed an issue with configuration validation
1 Like

Released v1.3.0.

This release makes this app quite complete with keyboard shortcuts for toggle and other enhancements as @Shamp0o suggested.


  • Global shortcut for toggle.

I have the same issue. Also with v1.3.0 on the latest macbook.

Thanks for making this, it is a useful functionality that I have been looking for. You could include some screenshots here or on the github page.

I wonder where the problem is. It is not for signing I guess. In that case, x64 wouldn't have worked. Have to dig in.

With hotkeys, now it is usable in Linux too.

I got the arm version to work with xattr -cr /Applications/ which as I understand just disables all warnings/errors (extended attributes). Thanks a bunch for the improvements.

Ah, this might be a important direction to explore.

Hi @uroybd, checking out your appimage on Linux here. All works well; kudos!

One thing I noticed in the settings: the dropdown with the notebook names lists only the first 100 notebooks (paging?). I have 145 notebooks here. Newly created notebooks won't show either.

I had a look in the Joplin database to see if I could find where the notebook for the Scratchpad is set, with the intention of just editing the notebookID manually. Also had a look around in the ~/.config/joplin-scratchpad folder, and ~/.config/joplin-desktop/ plugin folders, but couldn't figure out where the setting is kept.

Hotkey works fine in Linux here, fyi.

Thank you!

It's probably paging. Will fix this. Probably a notebook search instead of list will be more handy.

Also, settings are actually in the localStorage. I'm facing issues with filesystem access in electron. Hence localStorage.

1 Like