Revert version and get data back?

I am on Windows 7 and just allowed the upgrade to 2.12, got the error when trying to run Joplin,

"The procedure entry point DiscardVirtualMemory could not be located in the dynamic link library KERNEL32.dll"

Now I see I should not have allowed the upgrade.

Upgrade process wiped out my "Apps" folder on Dropbox which was my sync folder, but I was able to go online and quickly save a backup of the whole thing.
....and 2700 .md files
This is 7 years' work.

I uninstalled the new Joplin version and reinstalled the 2.11 that I had running before, but I still get the same error when trying to start it.

Is there any way to re-install an older version of Joplin and point it at my data and get it back working?

Do you mean that you get same kernel32.dll error when trying to start v2.11? If yes, then this means that the uninstallation of v2.12 was likely unsuccessful and you're in fact still trying to launch the newer version. Please make sure that Joplin has been completely closed, including the tray icon, and only then uninstall what you've got installed right now, and then re-install using the v2.11 installer.

That worked, it is all back - thank you so much for the quick reply. The tray icon was still there so I closed that and restarted the computer and 2.11 installed just fine. All the notes are there.

I reauthorized Dropbox for sync folder which I assume will eventually repopulate (it has not begun yet, the Apps/Joplin folder is still gone).

Thank you!!!!

I just ran "Re-upload to sync target" to Dropbox and everything seems to be going back into place.
Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.