Reset/restart Joplin

Joplin for Desktop 2.9.17 (prod, darwin) on a MacBook pro running Ventura. Also installed on a iPad Pro.

I think I have got the css and theme issues figured out, but not before I made a mess of things. Is there a way to reset Joplin to original state? I am tempted to delete and reinstall, but it's unclear to me what would happen to my notebooks. I am using Joplin Cloud, in case that makes a difference.

Many thanks

If you just want to clear all your custom styling, leaving your Joplin notes intact:

In a terminal type:

cd ~/.config/joplin-desktop

Then delete or rename or move out of that directory:

  • userchrome.css
  • userstyle.css

Alternatively, if you do not want to use the terminal, go into Joplin Desktop's settings and select Appearance.

  • Press Show Advanced Settings
  • Press Custom stylesheet for rendered Markdown
  • The stylesheet should open in a text editor.
  • Delete the entire contents (or cut/paste elsewhere) and save.
  • Press Custom stylesheet for Joplin-wide app styles
  • The stylesheet should open in a text editor.
  • Delete the entire contents (or cut/paste elsewhere) and save.
  • Fully quit Joplin (File > Quit)
  • Restart Joplin

This is mentioned in that link you were provided earlier by @Daeraxa

Also as these are just styling modifications, if you make a mess you can simply delete the stylesheets or the contents of the stylesheets. Then quitting / restarting Joplin will bring Joplin back to normal.

NOTE: This does not revert any changes you made elsewhere in Joplin settings or using any plugins you may have installed.

Thank you for your help. I need to read more carefully.

1 Like

Been there, done that (many times!) :slight_smile:

I was hoping I wouldn't have to ask more questions on this, but no such luck. i ran the terminal command, but how do I delete stylesheets? Where do they live? I've done some searching without success.

As mentioned in that link you were provided earlier by @Daeraxa

The actual location of the files is ~/.config/joplin-desktop on Linux systems and C:\users\<username>\.config\joplin-desktop on Windows systems

MacOS uses the Linux path.

If you have opened a terminal and changed into the joplin-desktop directory using cd ~/.config/joplin-desktop list the files there using ls

You should see that there are possibly two css files userstyle.css and userchrome.css

This is Linux but hopefully it should look similar

Delete them using

rm userstyle.css


rm userchrome.css

Alternatively, open whatever GUI file manager you have on your system, set it to view hidden files and folders, go to your home directory and then navigate to .config/joplin-desktop, find the css files in that folder and delete them.

The method I described above using Joplin itself will not actually delete the files but it will empty them and achieve exactly the same result.

Thank you again for the detailed directions, which I followed carefully. Even after deleting the two stylesheets and restarting, there were still odd things going on with formatting, so I cleared all the files out of the cache folder, and that did solve the problem.

So with your help and the updates to the wiki page, I am set. Thanks again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.