Home / GitHub Page

Problems with sync on linux client

To report a bug, please let us know:

Version: 1.0.169.540

  • Linux - KDE Neon

Completed: 07/10/2019 11:59
Last error: Error: Invalid property format: encryption_appli: id: 6e9cbdcf7f8a48d5b091d39c4bb905d3 parent_id: 640c2a5e73384ac0b7bd9e5ad5354d45 created_time: updated_time: 2019-10-04T21:00:31.559Z is_conflict: latitude: longitude: altitude: author: source_url: is_todo: todo_due: todo_completed: source: source_application: application_data: order: user_created_time: user_updated_time: encryption_cipher_text: JED0100002201715f27a8da0d4de9a215a73491a9fc17000576{“iv”:“vtsGks5aNKHxZ636iCmRzQ==”,"v


Hi,
I have Joplin on 3 devices. Its syncing to nextcloud and using encryption keys. It was working fine for a month or so.
Today I dont know wha thappend but suddenly on syncing I get the above problem. It does not sync then.
Im kind of novice with linux needs to be said… I wanted to uninstall and reinstall the app but Im not sure how since it is not in my linux distros appstore and I got it through the wget command on the website.
The sync works fine on my other devices though…

Maybe someone could just tell me how to properly uninstall it from a linux machine to then try to reinstall it again. Because it works on my other clients so something is just corrupt with this client I belivie…

If you delete the config folder it will be the same as uninstalling (without actually removing the app).

Simply open a terminal and type
rm -r ~/.config/joplin-desktop

Nice finally an answer!
Great I will try this first thing tommorow!

Ok so it seems I managed to uninstall the app. Started from scratch. now I put all my details and then hit sync. I get error msg:

Created remote items: 1.
Completed: 08/10/2019 08:40
Last error: Error: PUT .resource/25539cbb9daa41d3a142ab2a3bb7a1bb: (Exception Sabre\DAV\Exception\Forbidden) (403): <?xml version="1.0" encoding="utf-8"?> <d:error xmlns:d=“DAV:” xmlns:s=“http://sabredav.org/ns”> <s:exception>Sabre\DAV\Exception\Forbidden</s:exception> <s:message/> </d:error>

I dont get why its suddenly not working from this client…

When setting up sync with WebDAV do you need to input a password? Perhaps it’s wrong. Unfortunately I dont know anything about this, but it does look like the client might be rejected by your server.