Home / GitHub Page

Syncing forever

client versions: 1.0.195 (desktop, linux), 1.0.324 (android)
OS: Ubuntu Linux 19.10 x86_64

Since some days ago I was having issues with a locked file on my nextcloud provider, I choosed to start over in another folder: so I downloaded via web browser old folder and reuploaded it in another one using nextcloud client (too many files to handle with web ui), after that I started to switch folder into clients configuration and disable encryption (I was having also encryption issues), since then, apart of mine android client that performed successfully a complete sync, desktop clients keeps writing over and over again remote files which don’t produce any local file change in any of connected clients.

In console I didn’t found nothing but I have some lines in log.txt telling something about synchronization action, which I attach.log.txt (312.1 KB)

To make this long first sync I choose to run joplin at the same time in both desktops, could be this the problem source? Maybe their trying to write and rewrite over and over again same files?

What does uname -a produce? Please paste the terminal output here. Thanks

yes, it is

$ uname -a
Linux pavilion 5.3.0-42-generic #34-Ubuntu SMP Fri Feb 28 05:49:40 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

on both systems

1 Like

Good deal. It’s not the 5.5 bug. Can you try something crazy, though? I wanna see if maybe this fix fixes other issues here on Linux mostly.

Mine sync doesn’t freeze, it goes on and on forever, anyway I’ll try the solution posted and let you know how it goes.

I completely understand. I’m asking because that solution linked shouldn’t fix the issue it does but does for the time being and may do something for you. Your log shows the same error that pops up when the 5.5 bug happens.

I tried the procedure shown in video you posted but nothing seems to change.
In options -> web clipper I enabled and disabled service.

Thanks for trying that.

1 Like

Any other suggestion? A safe way to start over without losing data and possibly fix this issue? Any other suggestion that would fix this? Do you need further information to better diagnose the problem?

I don’t have other suggestions right now that are fixes but the more information you can give that’s very specific, including possible video or gifs of what’s happening, the better others can help you.

do you mean I need to show a gif or a video where the count of remotely updated elements slowly increases over and over again ? This is what happen everytime I launch Joplin and wait to begin sync , or I start it clicking the button. I think that is nothing interesting, the application seems going well, synchronizing elements and giving no errors.

just to understand better what is going on, I also sync via nextcloud client, the notes folder, I choose to disable encryption to be able to sync faster also other devices after that and then start to crypt notes from a speedy joplin for android : when joplin resyncs due to disabled encryption, it updates only encrypted notes or all notes?
I can see the note content of last note is changing over time, so something is running, I’m using this little script :
while true; do sleep 30; clear; fn=ls -rth | tail -1 ; head -30 $fn; done

But if I grep on md files and count the encrypted ones like this :
grep encryption_applied\:\ 1 * | wc -l
The number remains the same over time.

I realized that when disabling encryption, Joplin syncs all files, also ones already decrypted on webbdav location.

I’m saying this because I watched for a while these numbers:

  • recently updated file (today)
  • total files
  • still encrypted files

I used this snippet:
watch -n30 "find -mtime 0 | wc -l; find | wc -l; grep encryption_applied\:\ 1 * | wc -l"

IMHO this behavior is a bug, especially while the linux client is so slow syncing.
Could you please at least fix this? If you need an issue report I will do it.

I also have had a problem with this in the past week or so. Sync will keep spinning forever, but not sync some items. I’m running the latest (1.0.195).

I’m on a Mac, I’m not using encryption. I’m syncing via dropbox. I realize this isn’t enough info to debug the problem. What info would be helpful?

I checked the Sync Status window. Everything looks normal except for the line “Not downloaded: 3” which never decreases. Canceling and restarting the sync doesn’t change it.

Thanks!

-Tom