Problem with printing and PDF export on Joplin Desktop

Joplin 1.4.19 (prod, linux)
Client-ID: 033f5cb5639f494aaa94ba0896b01f1a
Sync-Version: 2
Profil-Version: 34
Unterstützter Schlüsselbund: Nein
Revision: de123ee (master)
Ubuntu 18.04.5 LTS, Gnome: 3.28.2, 64bit, ( HP Elitedesk i5-6500 CPU @ 3.20GHz × 4 )
CUPS 2.2.7 with a virtual PDF printer ans some real printers

In the past I used the pdf-export only a few times.
Today I tried to use the print option in order to print the notebook as an pdf-file. After some seconds the error message "could not print: no valid printers available".
I use CUPS for printing. Do I have to install a driver ?

After that I tried to export the notebook as pdf, but it just exports the first note of the notebook.
How do I export a whole notebook ?

I use an external HDD which is mounted and named SICHER. In the fileselector of import and export it is named SICHER1 and any access causes an error message.


I'm getting the same issue, only real difference is I'm on Ubuntu 20.04, I have a single real printer setup as a cups printer. So looks like an issue with finding cups printers.

No issues in Joplin for osx (v1.5.7). Print or print as PDF, both work fine for individual notes. Have you tried this beta version of Joplin, or at least checked the release notes ?

yes is fixed in 1.5.7, at least for me. Had to uninstall from the Ubuntu snap app as the install .sh did not see the current install. Then used install .sh with the pre release option to get 1.5.7 installed. Lost all of the content I had from the Snap install in the process (not sure why) but was only playing at this point anyway so no big loss. Also got an error from the .sh install saying there was an error in the install of the desktop icon, but seems to be there and working.

Sorry for missing this,

Snaps are heavily confined by default which is why CUPS access and the external hard drive are getting permission denied. If you use the GUI to install snaps, you'll see it has a little permissions button on the listing in the app store after you install it, and for a lot of snaps access to directories outside of $HOME such as external hard drives, and printing is not given by default. In general I'd recommend looking at the permissions interface if you see it appear because it does sometimes cause strange looking behaviour like this.

The reason the AppImage of Joplin can't find notes from the Snap version is because they're stored in different locations entirely, you'd be able to click the "open profile directory" folder in the snap version and copy it over to the same place in the AppImage version and expect them to work absolutely fine; but the Snap version has a different location because it actually backs up all the notebooks when it does an update meaning you can revert not only the entireity of Joplin but also the entire state of the Joplin databases in a catostrophic situation, and that just doesn't work with the normal folder location. (Also that sandboxing pokes it's head in again and wouldn't let it if it tried anyway)

There's future improvements to be made with snap in general to make the permissions management process better, mostly around allowing the apps themselves to request permissions more directly like on Android/iOs, and there's other improvements that Electron itself can make to allow printing and arbitrary file access in a Snap/Flatpak sandboxed environment without even needing those permissions in the first place, and I'll be sure to ensure they're working when they become available.

Again, sorry for the delay in response but I thought you'd appreciate the insight anyway.

1 Like