Unable to edit note in external editor

What I tried:

Ensure the text editor can be opened from the command line:


Now try and set the external editor in Joplin:

Tools -> Options -> General
    [trial 1] Text editor command -> Path: /home/moss/opt/Abricotine-linux-x64/abricotine
    [trial 2] Text editor command -> Path: /home/moss/opt/Abricotine-linux-x64/, Arguments: abricotine

Neither of the trials worked.

  • Joplin 2.3.5 (flatpak)
  • OpenSUSE Leap 15.3

Maybe you can take a look

I personally recommend the AppImage format

1 Like

Also have a look at @james-carroll's flatpak repo readme, it has a section on this
GitHub - MrCarroll/joplin-desktop-snap

I'm an idiot who can't read - see below

That's the snap, the flatpak is here

OP probably wants

--host /home/moss/opt/Abricotine-linux-x64/abricotine

I switched to from flatpak to AppImage because sometimes the app wouldn't even start; I had to restart each time.

In AppImage, I one had to do is:

Tools -> Options -> General
    Text editor command -> Path: abricotine

For the record if any one want to use flatpak version check out @james-carroll's answer above.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.