Problem sync with file system

I use filesystem to sync my desktop client and my android phone (with help of syncthing, a 3rd party folder sync tool) and it's been working fine for months. Now it seems to be broken by some upgrade but I'm not sure which end/version is the cause. My current desktop version is 2.6.2 running on Win10 1909, android client is v2.6.3 running on android 11.

Screenshot on the mobile end attached below:

Please kindly help, thanks!

1 Like

I hit this error when I first synced to file storage on my desktop and then tried to import those changes on a new install of joplin on mobile.

To get the sync working (I use FolderSync on android to sync to MEGA), I first sync the mobile via FolderSync to mega. I noticed this had some extra folders.

Then I sync an empty Joplin desktop with the changes from mobile.

This syncing setup then works when adding more mobiles and desktops to the folder that was first created by the mobile Joplin.

Then you will need to import any notes from your desktop via the desktop import I guess - I haven't tried this yet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.