Home / GitHub Page

Notification Center (MAC) Does Not Have Joplin

#1

Hi,
These instructions appear to be no longer functional:

https://github.com/mikaelbr/node-notifier/blob/master/DECISION_FLOW.md

I looked in the notification centre and found no Joplin, and so paid to download the Growl app, which in the flow diagram said was the alternative, it doesn’t suppourt Joplin either anymore (or at least it doesn’t on my Mac which may be to new for it).

How can I get my Mac to provide Notifications from Joplin?

Thanks

0 Likes

#2

Just wanting to point out that if a reminder app can’t send you a notification, it hasn’t reminded you of anything. Which means it doesn’t work at all. I also should get a refund from either Apple or Joplin for my purchase of Growl which was recommended to me on Joplin instructions page linked to above.

0 Likes

#3

Growl was last updated 6 years ago and is for 10.7 Lion, 10.8 Mountain Lion and 10.9 Mavericks. I do not even know, if it runs on later versions of macOS. Also, above link you posted is from an npm module used by Joplin to handle the notifications. If the documentation for that module is outdated, I suggest to open a ticket with them, not with Joplin.

Also, I’ve just set a notification and I received it. I’m not sure what your Mac issues are, but it’s not a Joplin problem. Otherwise I would not have received a notification either, but I did. So what does this tell you?
Furthermore it wouldn’t say Joplin in the Notifications Center, but terminal-notifier.

It doesn’t work for you. It works for me. So what now?

First of all, I suggest you fix your computer problems. Secondly, you can ask for a refund at the AppStore. Thirdly, Joplin is free software. Also: read the disclaimer.
There are several things that could have been done before buying Growl. Apparently you didn’t do any research, think it through, read the Growl reviews, or whatever. Asking for a refund from a free SW project is a joke.

You can’t even read how to provide sufficient information for a bug report. I really suggest you work on your attitude, otherwise noone is going to help you in this forum. At least I won’t.

0 Likes

#4

Ok. I admit I was frustrated in my 2nd post, having waited a day, and apologise for the bad vibes I created. Sorry.

I know that asking for a refund from Joplin, free software is a bit absurd and the growl dev I contacted said I should probably get one from apple and ask Joplin for help, which is what I am doing.

But moving on, that page I linked to is linked to from the joplin homepage:

https://joplin.cozic.net

The section on “Notifications” summarises that you should use the Macos notification centre and if that doesnt work use growl. So the joplin website it does say to do that, and then it links to the link I linked to, implying a level official-ness in the link I provided.

It nowhere says in the Notification sectoin on the Joplin website linked to above “terminal-notifier”. It does however say on the link I originally linked to “Mac Notification Center”. So I was simply following the instructions.

“terminal-notifier”, your solution, is presumably for the terminal application, not desktop. I mentioned “Mac”, I suppose its possible for you to not understand that “Mac”, mentioned in my first post, means the Mac desktop version. I hadn’t read anything about the terminal application and hadn’t noticed there even was one as it is not the norm.

I did reserach growl, I saw it had negative reviews due to being old and it might not work, but it was my only hope.

Suggesting I fix my computer problems is why I am here, asking for help on how to fix them. I patiently waited 24 hours and received no reply after spending a long time configuring Joplin, only to find it doesn’t notify me at all on desktop, and doesn’t vibrate properly on mobile.

There was no pop-up asking for a bug-report like with other apps and I admit I did not read how to submit one, so instead I thought I would ask on the support forum.

It seems like my angry response provoked you to an unhelpful reply from you, so I am apologise again for that.

I have looked up everywhere I can find how to add apps to the notification centre, I’ve tried being a guest user, Ive tried deleting and re-installing the app both on mobile and on desktop, I’ve tried asking on the forum.

If its a bug that could take months to fix then I just need to be told that and move on to another app - in which case the time cost to me of learning how to do that (submit big reports) and doing it would not be worth it (which is unfortunately because I love the principles behind Joplin) so I would have to find another app, having invested a lot of time into getting Joplin running already.

I also found out about Scott Joplin by reading about the creator of Joplin, who was inspired by the musician Scott Joplin and found his music to be be super cool, it was a great new genre for me to discover. I am a fan of Joplin, both the composer and the app.

I just need this tiny little thing to be fixed and it can work.

I am asking for help on a support forum.

It looks like I should have waited a few more days for a reply. I’ll talk to apple about the refund.

Your attitude, which I provoked, doesn’t encourage donations btw, but I am sorry for the anger I foolishly expressed. Sorry again, but the instructions need to be fixed.

Any help here would still be appreciated.

Edit: Now that I know its a problem with my computer, I can at least keep looking for ways to fix it. Still, any pointers would be welcome.

Thanks

0 Likes

#5

Hmm, I think that most people in this forum have a day job and reply and/or comment on an issue when they have time to do so. e.g. nobody replied to my post I created 3 days ago. While it easy to reply to a simple and clearly defined question, it might be not so easy for a question that does not even state the version of the release.

I’m not sure what you are reading but it for me it says:

macOS : >= 10.8 or Growl if earlier.

This means that you need Growl for macOS releases earlier than macOS 10.8.

Yea, I got that. I was talking about the macOS version as well. The test I ran was on macOS.

You do not add applications to the Notification Center. Never have, never will.
As soon as an application uses the macOS API to send a notification, an entry is created in the Notification Center for that application.

Joplin is a react-native application and uses Electron on macOS. Notifications are handled by the module you referenced, so really this module is sending the notifications. This is the reason why the entry you are looking for in the Notification Center is terminal-notifier.

This is ok, but you could have at least mentioned the version of Joplin you are having the problem with or the version of your OS. A problem report that only says it does not work is impossible to work on. You must admit that a bit more information is needed.
As mentioned before, it works for me, so most likely it works also for other people, so your problem might have to do with your setup. Maybe nobody replied, because they don’t have that problem.

In any case, more info is needed, since we have to determine what the culprit is.

A debug log always helps, because we can see, if there’s an error in Joplin or at least we can narrow down the problem.
So I suggest to set an alarm for time X and we can check what the log says at time X.
Additionally, maybe there’s an entry in the macOS system log. You can open the macOS Console application and look for any entries at time X. Other than that, I currently do not have any other ideas.

Just to be clear, I’m a user of Joplin, like you. I am not the developer.

0 Likes

#6

Ok, thank you for your help. I will reply with as much useful information as I can.

It is the most recent release of Joplin for Mac Desktop running MacOS Sierra.

Regarding the instructions in the notification section it says:

On the desktop and mobile apps, an alarm can be associated with any to-do. It will be triggered at the given time by displaying a notification. How the notification will be displayed depends on the operating system since each has a different way to handle this. Please see below for the requirements for the desktop applications:

Those instructions are then to either use growl, or follow the instructions I linked to in my first post which said which say to go use the Notification Centre.

I don’t know how to run “terminal-notifier” would you mind pointing me to resources that explain it or kindly explaining so you so yourself? (much appreciated). I cant find it from putting into spotlight or searching in finder, siri doesn’t have a clue and I dont know how to use terminal. The stuff you said before about reactive-native and Electon is all new to me so I’ll have to look that up. I am a keen learner but have a lot to learn.

As mentioned before, it works for me, so most likely it works also for other people, so your problem might have to do with your setup.

This is good news as it means it should be fixable! :slight_smile:

Cliking your debug link and having a go there, in the desktop application instructions.

19

Unfortunately there no file called “flags.txt” so that methed wont work (this is me entering it into spotlight). Putting in the other one (c:\Users\YOUR_NAME.config\joplin-desktop) (obv with my name instead) doesnt do anything, maybe its supposed to be put somewhere else rather than spotlight. So I’m having trouble creating a debug log.

I had a look through the system log as you have advised but dont really know what to look for. In a single minute of activity (when the alarm was set) there are hundreds of things going on and none of them give me a clue as to being to to with Joplin. Any ideas what to look for there?

Also it may be useful to know that in the system preferences for the notification centre I have multiple copies for (for unknown reasons) of the same apps. It might be to do with creating a guest user account that somehow ended up with all the same applications but nothing else creating a possible source for the double copies. I removed the guest user though but maybe that is relevant, possibly, if not let me know and I’ll call apple about that for help. I wondered if this was ‘clogging it up’, but I may be completely on the wrong track here.

Many thanks for your help, it is much appreciated .

0 Likes

#7

@gobblepotato, if you figure out how to get it working let us know, and we can add the info the readme. Personally, I don’t know as there are many notification systems, which is why we simply link to the documentation of the lib we’re using.

One thing I’ve noticed is that node-notifier had a few new versions recently so perhaps we need to upgrade and it could fix some issues.

0 Likes

#8

Hi Laurent thanks for the reply. My current plan is to upgrade my OS to the newest one Mohave and see if that fixes it (plus I want to upgrade anyway) but it will take a few days.

In the meantime and tips or ideas would be great. I’ll update after the update, next week sometime .

0 Likes

#9

Yes, as I have explained in my previous post:

macOS : >= 10.8 or Growl if earlier.

This means that you need Growl for macOS releases earlier than macOS 10.8. You are using High Sierra, not a macOS version prior to 10.8. So you are not supposed to use Growl.

You don’t run terminal-notifier. Joplin sends a notification and internally terminal-notifier is used. I only told you about terminal-notifier, because Joplin does nor show up in Notication Center.
So, if you want to change the behavior of Joplin’s notifications, you will have to change the settings for terminal-notifier in the Notification Center.

This is normal, because you have to create it. The first line of the instructions says:

Add a file named “flags.txt” in the config directory

open a terminal and enter the following comnand (on one line - discourse might have added a line break):

cd ~/.config/joplin-desktop && echo "--open-dev-tools --log-level debug" >flags.txt

Done.

I’m sorry, but I’m starting to wonder, if you read the text as it is written or if you just pick and choose a few words from the text. You asked questions again that I have already explained in my previous post. I’m not sure what else I can do. I think I have expressed myself rather clearly, so I’m at a loss.

0 Likes

#10

The ‘terminal-notifier’ entry in System Preferences -> Notifications only shows up after the first notification by Joplin is given, not before, maybe that is the problem gobblepotato is having. Make a todo-entry and set a time on it, and you will get a notification, and the ‘terminal-notifier’ will be there in System Preferences -> Notifications. ‘terminal-notifier’ is a very confusing name though!

0 Likes

#11

Ok, thanks for telling me what to type in to create the file, that is helpful. The file flags.txt file appears now.

The console tap that appeared in Joplin (as the instructions said it would) didn’t do anything, it just stayed blank/empty.

I created a to do, set an alarm, synced, the sync worked as usual, but the alarm didn’t go off on desktop and no change in the console inside of Joplin.

The instructions do say “add”, my mistake.

Going back to those instructions:

Now repeat the action that was causing problem. The console might output warnings or errors - please add them to the GitHub issue. Also open log.txt in the config folder and if there is any error or warning, please also add them to the issue.

The console did nothing. In the log.txt file I wouldn’t know what to look for but nothing says error or warning. The instructions then say to add them to the issue, I don’t know which issue, nor how to add them, or if there is anything wrong with them.

So still stuck, but have learned a few things so thank you, it hasn’t been or nothing. But I am determined to get this working as well as continue to learn.

0 Likes

#12

You don’t run terminal-notifier . Joplin sends a notification and internally terminal-notifier is used. I only told you about terminal-notifier , because Joplin does nor show up in Notication Center.
So, if you want to change the behavior of Joplin’s notifications, you will have to change the settings for terminal-notifier in the Notification Center.

I don’t know how to do that. How do the notifications appear then? If they are not in the notificatin centre, out of curiosity.

0 Likes

#13

Hi Varaljop thanks for chipping in,

From what you have said, ‘terminal-notifier’ only shows up after the first notification is given. I have set countless to do’s with alarms, none of them cause any notification on desktop, so it looks like from what you said those alarms I set wont send me a notification until one of them has.

Out of curiosity does terminal-notifier appear like one of the apps in the system-preferences-notifications or completely different?

Thanks

0 Likes

#14

Just as one of the apps. 20

0 Likes

#15

Have you tried to uninstall the Joplin app (just move it to the trash and empty), and re-install it?

0 Likes

#16

I tried doing that early on in my attempts, but haven’t done recently since these alterations. I’ll do it again.

Edit:
Reinstalled, but nope, no luck.

0 Likes

#17

Ah thanks for the screenshot! This make it much easer for me to visualise how this would even send me a notification.

Is there an app from the app store I could simply download to get terminal-notifier? I dont see any called that but there are some that look similar. Just looking for simple solutions. Though I also want to increase my understanding.

0 Likes

#18

Ok, let me try this one more time. terminal-notifier is not necessarily an app, it could also be a script.

It is bundled with Joplin, so if you don’t get notifications, there must be an error somewhere. Either in the debug log or in the system log of macOS.

There are different implementations of terminal-notifier apps, scripts, tools available. MacPorts has terminal-notifier as well as brew.
The source code is here: https://github.com/julienXX/terminal-notifier

Please note that I have no idea, if the module that handles notifications uses the same terminal-notifier. As I mentioned before, there are several implementations out there.

0 Likes