Notes with failed geocoding HTTP call fail to sync

Joplin version 1.0.147 (Prod, Linux)
Using manjao Linux

I noticed the sync is not working expected and wanted to dig a bit more into what’s going on. I found out some notes are not “leaving” my laptop machine and don’t get uploaded to OneDrive.

Looking at the log file I saw this.
FetchError: request to https://api.ipify.org/?format=json failed, reason: getaddrinfo ENOTFOUND api.ipify.org api.ipify.org:443
at ClientRequest. (/usr/share/joplin/resources/app/node_modules/node-fetch/index.js:133:11)
at ClientRequest.emit (events.js:182:13)
at TLSSocket.socketErrorListener (_http_client.js:391:9)
at TLSSocket.emit (events.js:182:13)
at emitErrorNT (internal/streams/destroy.js:82:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:50:3)
at process._tickCallback (internal/process/next_tick.js:63:19)"

I have the geocoding option turned on under notes. trying this link on my browser showed it’s blocked by my university firewall.

I think some notes where this call to get their lat and long fails are not getting uploaded for some reason.

Wanted to report a bug, great work and thank you for the great application

Getting the geolocation is unrelated to sync, these two parts of the app are not connected at all so one can’t make the other fail.

It’s possible you have other errors in your log, which might explain why sync is not working for you.