Notebook disappeared after adding an icon to notebook title

One of my notebooks disappeared after I added an icon to the title. I saw the icon next to the title so I moved on to other work. When I came back the notebook had disappeared (possibly during a sync cycle). My other notebooks are unaffected. I have successfully added icons to the title of other notebooks without issue before this.

I attempted restoring my notes from the database.sqlite file as outlined in "Restoring Deleted Notes" Restoring Deleted Notes . Most of the missing notes are not there, but I can see a few of the missing notes in the sqlite file. When I try to restore these notes, Joplin adds an "Untitled" note to "Restored Notes" that is empty. I have tried many times with the same result. To verify that I'm following the steps correctly, I added one of the notes that I manually deleted previously and that note gets added to "Restored Notes" like normal, with all the content there like normal. For some reason, the notes from the notebook that went missing are completely empty when I try to restore them with this method.

I don't know what else to do. Anything else I should try?


Required info:

  • The version you are using.

Joplin 2.7.15 (prod, win32)

Client ID: cc0f20411c2a400aa7d1d18cfe70a4db
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes

Revision: 8352e23

  • If it is a sync issue, please let us know what you are syncing with.

OneDrive

  • The operating system you are using.

OS Name Microsoft Windows 11 Pro
Version 10.0.22000 Build 22000

  • If you can also please provide a log, as described here: joplinapp (dot) org/debugging

There are literally hundreds of errors listed. There is so much information in the console so I'm not sure which info you are looking for. This error is the same one that was listed above the "Synchronize" button:

image

The error says that all data in the sync target has been deleted and therefore the sync was interrupted.
Is the OneDrive folder empty?

Do you mean this folder?:

Fwiw, I quit and restarted Joplin and several more of my notebooks have disappeared, now. The issue may be unrelated to adding an icon to the notebook title.

I have no OneDrive target, but did you move the folder?

I'm starting to get concerned that maybe I'm the one that screwed it up ... I deleted the folder but not recently (explanation below). Other than that, I have not moved the folder.

When I installed Joplin on this computer, it placed this folder on my Desktop. When I installed Joplin on my older computer last year, Joplin didn't put a folder on the desktop. I thought the inconsistency was was odd. The contents of the desktop folder were mostly empty compared to the folder on my older computer so I moved this folder to the Recycle Bin.

I opened Joplin to see if it would work. The app worked. My notebooks worked. Joplin sync worked. Joplin simply put the folder back on my desktop so I have left it there since. I have been using Joplin in this state for several weeks, adding to previous notes and creating new notes. I have not had any issue until today.

Also, I don't understand what you mean by "I have no OneDrive target"

This refers to me.

I think you have messed up the sync targed, but not 100% sure.

Do you use OneDrive or Files sytem in Joplin as Synchronisation target? The Path looks like more as a File sync path.

The Synchronization target is set to OneDrive. I have not changed it recently.

Could you post a screenshot of your sync config.

Is this what you mean?

JackGruber, thanks for your help with this. I'm just going to accept my loss and move on and recreate my notes from scratch. Hard lesson to learn that syncing is not the same as backup. You may close this thread.