Home / GitHub Page

No notes visible after encryption and update, Linux

Hello friedly support and community,

I am using:

Joplin for Desktop
Joplin 1.2.6 (prod, linux)
Client ID: b9125ae92e4749eabf380817f00a044b
Sync Version: 2
Profile Version: 34
Keychain Supported: No
Revision: f5f117c (master)

on a Linux system:

Kernel: 5.4.0-48-generic x86_64, 
Distro: Linux Mint 20 Ulyana 
Base: Ubuntu 20.04 focal

The data is in a folder that synchronizes with pCloud so that I can access it via WebDav on other devices, namely an iPad.

After having had trouble with encryption on more than one device (the data was decrypted but was still shown as encrypted and inaccessible on my iPad), I updated from Joplin-1.0.227 to the current version 1.2.6.
After updating, my data "disappeared", that is, no folder and no note is visible except for 6 notes (the welcome notes from installing joplin on my other device). See the image:
Notes not visible

The data is still there in the "directory to synchronize with" (see the image):
Joplin data on drive

The data is also still sort of in the joplin system, for instance in the Tools >> Synchronization Status (see the image):
Synchronization Status

As the problem seemed to be related to encryption, I tried to re-encrypting all notes. It worked, all 15000+ notes and 8000 additional resources were re-encrypted, it took quite a while -- but the notes and notebooks are still invisible.

I then tried to switch off all encrypion, which worked, again, but still the notes are not visible.
This is the Encytion Status (see the image):
Encryption is disabled, decrypted items 15.000+

Nevertheless only the same six notes are still visible.

Any advice on how to get the notes back and accessible into the system?

I managed to get my notes back by deleting the
~/.joplin
and
~/.config/joplin-desktop
~/.config/Joplin

Then I started Jopin again, and then indicated the previous sync folder. Joplin recovered the notes, and strangely, still knew about the encryption and still had the encryption IDs (where were these saved if not in the three places, I wonder?).