Home    |    GitHub Page    |    API    |    FAQ

Nextcloud syncing issue on Android 10 - Changes do not appear

Hi everyone!

I have been a happy user of Joplin since mid 2020 and I don't regret it! But, lately, I have run into more syncing issues than I ever had using Joplin.

Nevertheless, Joplin is a great piece of software and I have sufficiently made myself at home to consider it as my primary notetaking app for all purposes, so I won't call it quits just yet!

Quick note, I'm using Joplin on multiple devices with Nextcloud as my syncing target:

  • a Windows 10 computer running Joplin 1.5.14
  • an Android 10 tablet running Joplin 1.5.1
  • an IPhone 6 under IOS 12.4.9 running Joplin 10.5.1.
  • I have set up a web-hosted instance of Nexcloud 20 purchased from Cloudamo as my syncing target.

Here is the problem!

After a bit of learning and table flipping (figuratively!), I have set up Nextcloud as my syncing target on the above mentioned devices: it worked like a charm, well until I started experiencing syncing issues between Windows 10 and Android 10.

Synchronisation completes successfully, but changes to notes made on Joplin for desktop do not appear on Joplin's Android app. Instead, it shows an unmodified version of the same note.

However, in my writer's daily workflow, I absolutely need to have the latest revisions of my notes on my three devices to stay productive!

A few observations:

  • The syncing targets quote on quote "seem correct" and point to the same directory at https://(insert domain name)/remote.php/dav/files/(insert username)/Documents/Joplin
  • I have no other syncing issues to report between my other devices.
  • I'm a total Nextcloud beginner when it comes to server hosting, so I'm testing the waters first before making a final decision on which instance I'll be using. I'm not going back to syncing with OneDrive (syncing issues!) or Dropbox (issues not related to Joplin) for the life of me!
  • Your advice and guidance throughout the debugging procedure would be appreciated!

You may find attached a log file detailing the issue:

syncReport-1610311735277.txt (529.3 KB) .

Thanks in advance for your help regarding this issue and thank you for reading!

Greetings!

Paula

Here is my take, it may well be superseded by better advice from the developer, or other users with similar issues. There have been cases where quitting Joplin while a sync was in process has caused problems in the cloud which later don't go away. You have to make sure that this wasn't the case for you. Here is how:

Here is what I would do:

  • make local backups, and backups of the backups,
  • clean sweep of all Joplins instances including profiles,
  • reinstall Jop on win10 and write a few short simple text notes for testing,
  • sync with a different nextcloud target (I am using a free server in Switzerland which works just fine)
  • reinstall Jop on Andr10 and see what goes wrong if anything.

Supply the logs from both devices to the forum.

Good luck

Thank you for your advice @ajay, now that you mention it, I might need a clean reinstall from scratch, because I have switched between syncing targets quite a lot since I looked for an alternative to replace OneDrive.

I will follow the instructions you suggested and get back to you!

Kind regards!

So...

Quite a lot happened!

I have taken notes to memorize it all and give back to the forum all the information I could possibly gather. This is going to be long!

First thing first, I have updated all my Joplin apps in the process:

  • from Joplin 1.5.14 to Joplin 1.6.6 on desktop
  • from Joplin 1.5.1 to Joplin 1.6.6 on Android
  • from Joplin 10.5.1 to Joplin 10.6.2 on IOS

Before I applied all the steps you suggested @ajay, I tried to uninstall and reinstall Joplin on Android 10 only. Sync worked first try, but then after some back and forth testing, the same issue happened, but in reverse. Test content created on Win 10, synced on And 10 and modified on And 10 wasn't showed modified back on Win 10.

Quick note, I had a suspicion, as you mentioned it, that a connection problem was the issue, since I may have used Joplin on the train some time ago with unstable connection.

  • Before the fest started, I made backups, of course!
  • Uninstalled/reinstalled Joplin on And 10.
  • Reauthorised Joplin's access to my Nextcloud server.
  • First sync completed with no errors.
  • Created a new notebook and a test note on Win 10 to check config. Sync was again successful.
  • After some back and forth testing, it appeared that modifying the note on And 10 did not show these changes on Win 10.

Thus, I went the other route and uninstalled/reinstalled everything!

  • Uninstalled all Joplin apps, including profiles on Win 10.
  • Revoked all Joplin recent accesses to my Nextcloud server to ensure there would be no conflicts arising from the debugging process.
  • Deleted Joplin's Nextcloud directory.
  • Created a free Nextcloud server at Woelkli for testing.
  • Reinstalled Joplin on all devices. (updating to latest versions available in the process as stated above)
  • Created a few test notes on Win 10 that were synchronised to the new instance successfully.
  • But when moving on to set it up on And 10, nothing appeared after synchronisation, apart from Joplin's default notebooks.
  • Set up new config on IOS and everything synchronised seamlessly.

Conclusion, as far as I can understand, this is a strange case scenario in which Win 10 and And 10 don't communicate so well together, whereas there is no sync issue on the side of Joplin for IOS. Nota bene, I have just updated all my apps and set up a brand new Nextcloud instance as my syncing target.

This is all I can do to contribute, if it can help!

Kind regards!

Log files:

Latest sync on Win 10 after reinstallation: LatestSyncWin10Reinstall.txt (114.1 KB)
Latest sync on And 10 (that failed) after reinstallation: syncReport-1610454342416.txt (19.4 KB)

Edit: I should have looked twice for a workaround, this post solved the problem! Using WebDav instead of Nextcloud as syncing target did the trick!

1 Like