MultiMarkdown Table Tools Plugin

Hi, I'm new here in the forum. I've worked on yet another table plugin, that can (among other things) format and minify MultiMarkdown tables without breaking merged cells. It's kind of a toolbox with many features. If you're interested in details and more screenshots, checkout the GitHub repo.

GitHub repo

Demo

typing-demo

Features

  • Create new tables with a dialog.
  • Format and minify Markdown tables (without breaking MultiMarkdown tables).
  • Add, delete, and move table rows and columns.
  • Align text left, center, or right.
  • Adds hotkeys, such as: Jump to next or previous cell with Tab and Shift + Tab.
  • Paste HTML or CSV tables as Markdown.
  • Convert tables between HTML, Markdown, and CSV.

If you don't like or care about MultiMarkdown, you can also change the flavor to "GitHub-Flavored-Markdown". I strive to make the plugin customizable to most people's taste.

However, it's not perfect... if you find any bugs, please let me know. Either here, or as an issue on GitHub. (I've mostly tested the plugin in Joplin pre-release v2.10.3, but it should work fine in v2.9.x). Any feedback and questions are welcome! I cannot guarantee that I'll find the time to implement every suggestion/bugfix and answer every question, but I'll see what I can do.

Cheers!

7 Likes

Thank you for this!

Just a question here: I noticed there's this option " Has header" in table insertion dialogue. Could you tell the use case behind unchecking this option?

It seems like Joplin renderer doesn't render table without the header -- so unchecking this option effectively allows inserting the table that cannot be rendered. Any hints why user might want that?

Thank you very much for the plugin! it greatly improves the workflow with markdown tables :heart:

Hi graphit0!

It seems like Joplin renderer doesn't render table without the header -- so unchecking this option effectively allows inserting the table that cannot be rendered. Any hints why user might want that?

MultiMarkdown allows tables without header, however the MultiMarkdown extension is disabled by default in Joplin, which is why the table isn't rendered. If you want to, you can enable the extension in the settings under "Options" → "Markdown" → ":white_check_mark: Enable multimarkdown table extension (wysiwyg: no)" (option at the bottom)
Otherwise, just ignore the checkbox.

Thank you very much for the plugin! it greatly improves the workflow with markdown tables :heart:

You're welcome! :slight_smile:

1 Like