Home / GitHub Page

Multi-level lists get

Hi! Here’s something I’ve been wondering about for a while.

I use the latest version on Linux x64 (Ubuntu 19.04)

For some reason when I do multi-level lists like this example, after saving the list just folds itself to a 1 level list i.e.

- 1
- 2
    - a
    - b
- 3

short after saving would turn into:

- 1
- 2
- a
- b
- 3

so I lose the multi-level which makes the lists kinda hard to figure out

anyone else has this bug?

This happens when saving in an external editor? Or when Joplin syncs?

I copied what you wrote into Joplin on my computer and it renders correctly.

In the native client, no external editor. I never see it happening so yes it seems to happen when syncing. My last paragraph is okay, what I typed yesterday has decreased indents to initial (0) level.

It’s not about rendering, when typing it everything is okay. It’s later when I get back to editing it, then the list levels have resetted. So maybe something on syncing.

FYI I have encryption enabled.

Very weird, I copied your text into a note and I’ll let it sit for awhile to see if I run into the same issue.

I’m not reproducing this bug on my end, Nothing has happened to the list since yesterday.

I’m still trying to get the exact steps to replicate the issue.
It always happen that way:

  • I finish my day, everything seems okay.
  • I wake up, random multi-level lists are now bottomed down to a single level.
  • Sometimes my latest notes seem okay, I scroll up to what I typed earlier and oops it’s on a single level.

Really now constant way of replicating it. I’ll update this thread whenever I find a way to repeat this issue.

I’ve also trying to reproduce this without success (although I’m on macOS). My lists are still all fine. I’ve never experienced anything like this.

Do you have a cat? Or a poltergeist?

The only explanation I could think of is that you opened the note with an external editor, but never stopped watching it. Then for some reason the editor autosaves and trims all leading whitespace characters. (Without you noticing.)

No I assure you, my home has been ghost-free for the past years since I invited an exorcist all seemed well? I thought so at least! hehehehe XD Kidding aside, there’s nothing you listed that I’ve done or have been happening here lately.

I use Nextcloud to sync everything, I’ll try to check if something else than Joplin tampers with the note files. I never even opened any notes in an external editor yet. There must be /something/ but I really don’t know what.

Haven’t been happening this past weekend, I’ll update the thread if I find out any more details.

Are you able to run SQL dump of this particular note when it’s fine and when corrupted?
To see whether the spaces disappeared in raw note?
(Slightly high-level troubleshooting)

It just happened twice today, this is exactly what I did: I added a few items to my list, switch note, tweaked another list, switched back and what I typed was on the same level. Just tried to replicate it repeatedly without any success :frowning: I really wonder what’s up with that. (FYI: notes from the same notebook)

About SQL dump, how can I do so?

Just google the usage of sqlite3 command and SQL query commands.

This happens as much as before, here’s how I 100% replicate the issue:

  • Look at this note here: http://0x0.st/zI4N.png (notice the last empty list element, it IS indented)
  • I switch to another workspace (I use i3wm on linux)
  • I switch back to the workspace with Joplin and bam:
  • The item has been pushed back to the left: http://0x0.st/zI4b.png

I will try to provide SQL dumps as required, it’s the first time it is infinitely reproducible so I’m kind of excited to finally have a way to demo it since it’s SO annoying!

LOL thanks for such a good helpful reply! I know how to play with sqlite databases.
I just don’t know which exact table and how to fetch that specific note within Joplin’s DB structure.
I’ll figure it out on my own :wink:

Isn’t it because you press some key, like Shift+Tab, when switching workspaces?

That’s a legit good point!

When switching workspace I press these:

  • SUPER+Page Up or SUPER+Page Down
  • CTRL+SUPER+Left or CTRL+SUPER+Right

These are all the possibilities, is there any of them that could interfere with Joplin’s?

Damn! Just tested something:

  • I click on the workspace I want to switch instead of using the key bindings: nothing happens
  • I use the keybindings: the indent shifts

You just found the biggest clue yet! Thanks so much :smiley:

EDIT: It happens specifically with CTRL+SUPER+LEFT / CTRL+SUPER+RIGHT! Found the culprit!

I stopped using the CTRL+SUPER+PageUp/PageDown and only use SUPER+PageUp/Down and now it doesn’t happen anymore. I’m SO HAPPY! There was interferences between my i3wm bindings and Joplin’s

Thanks a whole lot!!!