Merging cells in table fails

Operating system


Joplin version


Desktop version info

Joplin 2.13.15 (prod, darwin)

Client ID: redacted
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 7d2c1c0


Rich Text Editor

What issue do you have?

Creating a table with four columns. I need some rows to be full width to accomodate wide text. Easy, I merge the cells. All appears fine until I leave the note and on return the cells have split. The first column is now wider than the others in order to accommodate the wide text. There's an error message, see the attached screengrab.

Any advice?



Still can't fix this if anyone has any clues?

Could you please explain which command / commands exactly you use in order to "merge the cells" as you say ? I cannot find a merge command in the wys editor, and I hope you are not editing the cell structure chars directly in the MD editor - do you ?

Here's a screen grab where I've created a new note and added a 4x5 cell table. I've selected a row and from the dropdown table menu selected Cell -> Merge Cells.

In this quick test it works. However in my 'live' note it also worked but appeared to fail after switching away from the note and back.

And in fact that's what happens here. I type in the merged cell, move away to another note, come back and the cells are no longer merged. The first column is wider than the others as the text exceeds the width of the cell.

There's no 2.16 version

When you move away from the note Joplin has to convert it to Markdown and plain Markdown does not support merged cells.

When you first use the Rich Text Editor (RTE) a banner appears that says there are limitations. It links to this page where it says (my emphasis):

However there is a catch: in Joplin, notes, even when edited with this Rich Text editor, are still Markdown under the hood. This is generally a good thing, because it means you can switch at any time between Markdown and Rich Text editor, and the note is still readable. It is also good if you sync with the mobile application, which doesn't have a rich text editor. The catch is that since Markdown is used under the hood, it means the rich text editor has a number of limitations it inherits from that format:

However it seems that the "Table" toolbar menu icons (shown below) do still include actions that are not supported (merge, cell background colours, cell border lines and colours etc.). I am not a coder but I guess (and it is a guess) that this is a part of the component imported to handle tables and possibly cannot yet be disabled.

You can create merged cell tables in the Markdown editor after switching on "Multimarkdown" in the Markdown section of settings. The RTE will display the table with merged cells. Unfortunately if you then edit the note at all (not just the table) in the RTE this formatting is again lost when you leave the note.

Thanks, that's all helpful. I may or may not have RTFM and even if I did, probably forgot or didn't realise it was relevant to me and this situation.

Sorry, typo I guess. I did also report 2.13.15 in the next line.

You may want to try v2.14 since it has improvements for tables. In general now if a table cannot be converted back to Markdown it is kept as HTML and that should work with colspan too (if not it's a bug which should be fixed).

Joplin for Desktop

Copyright © 2016-2024 Laurent Cozic
Joplin 2.13.15 (prod, darwin)

Check for updates -> Current version is up to date.

2.14 is available somewhere else?

2.14.x are currently pre-releases (release candidates) of the version that is due to be published in the first week of March 2024.

If you tick the box to get Joplin to check for pre-releases it should appear as an update dialogue. Alternatively you can download directly from GitHub. Click "Assets" to see the downloads.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.