Masterkey needed


my Joplin worked fine for multiple devices until today. Today I added a new device (with Ubuntu 22.04) and added the (same) masterkey to this new joplin. All seemed to work fine but after I synced the devices, I am able to the the error message "Mindestens ein Hauptschlüssel benötigt ein Passwort" which means minimum one masterkey needs a passwort on one of the old devices. The problem is that if I click at the master password I am able to see the correct masterpassword and this masterpassword is the same and the correct one.

I even deinstalled joplin via snap but after I reinstalled it I see the same error message again after sync the device and set the passward for encrytion on this device.

The devices where I have this issue have the following version:

Joplin 2.7.14 (prod, linux)

Client-ID: 766a1e8788584a7093f8ccf36d6a13af
Sync-Version: 3
Profil-Version: 41
Unterstützter Schlüsselbund: Nein

Revision: 75cc9d7f9

Update: I noticed that when I add a new node to the new joplin it is not replicated to my IOS device.

Right now I am completely out of any ideas

Could you provide a screenshot of your Encryption screen please?

Sure. Please find the picture attach.

Maybe I am doing something wrong in general when I add now joplin devices. I simple configure the nextcloud sync, then I add the key for encryption (always the same) then I leave the menu in order to start the sync.

And if you enter the password for key 5b6... what does it do?

If I use the (same) encrytion key for the password field and I click at "Speichern" (Save) the field is cleared again and is empty

Oh that's right, there's an issue in that version. Could you try prerelease 2.8 to see if it fixes the issue? Release v2.8.4 · laurent22/joplin · GitHub


was able to add the password but the result is the same. The notes are encrypted and the error message is still available.

With 2.8?


$ ./Joplin-2.8.4.AppImage
xdg-settings: invalid application name
Try 'xdg-settings --help' for more information.
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
[28939:0427/] InitializeSandbox() called with multiple threads in process gpu-process.
(node:28902) electron: The default of nativeWindowOpen is deprecated and will be changing from false to true in Electron 15.  See for more information.
(Use `@joplinapp-desktop --trace-warnings ...` to show where the warning was created)
[28902:0427/] After loading Root Certs, loaded==false: NSS error code: -8018
(node:28994) Warning: Setting the NODE_TLS_REJECT_UNAUTHORIZED environment variable to '0' makes TLS connections and HTTPS requests insecure by disabling certificate verification.
(Use `exe --trace-warnings ...` to show where the warning was created)

I had the same issue, but an upgrade to 2.8 solved it!

Maybe I did something wrong, but I simple deinstalled the snap, change the right to run the appimage. The I added the nextcloud parameter and added the missing key as requested.

Is there anything I could test in order to help solving this issue ?

Hello laurent, do you have any hint for me, how I can continue with joplin without loosing the complete data ?

Does ist make sense to create a bug ?

Did you test the last version 2.8.6 ?

Yes, I tested it right now.

I deactivated the key that was marked with a red X.
I deleting the .config/joplin-desktop directory.
I installed the newest version, I added the masterkey (as always the same masterkey), I added it to the deactivated key. Now I don't receive the yellow error message at the top of the windows but all notes are encrypted.

It doesn't help that you have so many master keys when one would be enough, and apparently the one key that was used to encrypt everything has a different password.

I will try to replicate this locally so that it gives the option to set the password for that extra key.

Thank you very much for your reply.

I have found a relatively recent backup (jex file). I assume that the images are also included in this file. So you do not need to reproduce the problem.

One more question. I did not create the many masterkeys on purpose. I assume that a masterkey was added for each installation (in some way) on a device, but that's just a guess. Could that be the reason for the high number?

What can I do to avoid this or what is the recommended way to add a client if the new device is the reason ?


The recommended way is to set the sync target on the new device and sync. Then it will pick up the master key from the sync target without creating a new one.

So just as for my understanding. I should wait until the sync finishes instead of adding the key before the sync finishes, because otherwise this adds a new key for encryption and than added to my whole system.

Did I understand that correct ?

Yes, that's correct