Massive Conflicts

Operating system


Joplin version


Desktop version info


Sync target


What issue do you have?

I have been living in data hell these past few weeks, trying to recover notes and notebooks that were lost when a single Dropbox target was used to sync different Joplin installations. If you care, see Help with Notebook Recovery for more info. However, among other problems, I'm left with three conflicts folders:

Conflicts (attachments) 247 [appears colored black]
Conflicts (attachments) 42 [appears colored black]
Conflicts 138 [appears colored red]

I have tried the Conflict Resolution plugin but it only appears for notes in the red Conflicts notebook. For all of the 138 items in that notebook, "resolve conflict" results in a dialog that says "Not Found" (see screenshot).

For most of the conflicts, there is no text but simply a highlighted link to another .pdf or .docx documents (see screenshot). The links all look something like C:/[user]/.config/joplin-desktop/resources/83f08bb6ff5346aa8a80e56b18bcebce.pdf

How can I clear these conflicts and recover the content?


Dec 2 conflict.png

The fact that nobody in this very helpful community has responded to this makes me think that nobody really understands conflicts, why Joplin creates them and how to resolve them. This really needs to be another focus for future development.

Here's how I resolved this situation. First, I opened Joplin on a second computer, where I found only the two 'black' Conflicts notebooks mentioned above. I did a spotcheck of the files and found enough of them attached to existing notes, that I felt comfortable deleting the notebooks (although I first exported them for safekeeping). Those two notebooks were successfully deleted from my other computer via Sync.

I returned to my first computer where the red Conflicts notebook remained. All of these items were also attachments, but none of them could be opened. They also could not be exported because Joplin said they were empty. So I deleted this notebook.

All Conflicts are now gone.

1 Like

I get a lot of conflict sometimes too and I have no idea why. I am a single user and I run Joplin on Windows, Android, IOS and Linux terminal. I never use any of these clients at the same time, I still get conflict files especially with attachments.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.