Homepage    |    GitHub    |    API    |    FAQ

Lost photos (resoures) on PC

I wonder if someone is able and kind enough to offer some help with a new problem that has just started in the PC version of my Joplin Notes after months of no issues. [details below]

I have just started to get some photos (resourses) that don't show on my PC version that are showing in Joplin on my iPad and iPhone and Linux Notebook versions.

Coinsiding with this I have noticed that I am getting a status message that says completed with the usual announcements like Updated remote items etc. but then Fetching resources: 3/10 that doesn't change even after sync has finished.

Below are some details of my install including paths. It is the resourses path that confuses me as I am syncing Joplin via OneDrive but notice that photos (resourses) are also pointing to my C: drive which sort of indicates that Joplin is using duplicate paths, which I don't want (especially not using the C: drive).

I have tried closing down Joplin and re-booting the offending PC. Then I ran a sync again but still the photos only show a "download" icon on the PC, whereas the photos show on all three other devices. Note: this is only happening with a small number of records.

I'm wondering if I need to uninstall Joplin and re-install. However I'm reluctant to do that until I understand the anomoly in the "resourse folder" duplication.

Any advice will be much appreciated. Cheers Anton.

PC

2021-08-10 v2.1.9
2021-..... v2.4.9

  • Install path:
    • F:\Programs\Joplin\Joplin.exe
  • Resourses path:
    • F:\User-f\antonvs\OneDrive\Apps\Joplin.resource
      OR
    • C:\Users\Anton.config\joplin-desktop\resources\2bdce77a01944d8989139f0291ec1779.jpg (this photo shows OK)
    • Lost file path:
      • C:\Users\Anton.config\joplin-desktop\resources\10a6258211b64b26a02ae3ac1292ed7e.jpg (only shows download icon)

...

I have tried a bit more experimenting.

If I produce a new note on my PC and add a photo, it syncs to all other devices.

If I produce a new note on any other device (including the Linux notebook) the photos sync and show everywhere else except the PC that has the issue.

I notice that in my OneDrive status window some resources go to the a lock folder but then disappear from that in time

And this screenshot shows the strange fetching resources notification...

2021-10-12 16-23-40 cc1

Here is a copy of my sync report (but it doesn't show any conflict):

I have done some more checking and find that the missing resources (photos) are in one folder (on the F: the Joplin resource folder drive but not in on the C: drive. But it still raises the question as to why Joplin is looking for resources on the C: drive but syncing to the OneDrive folder on F:....


I have looked in Joplin settings and aside from setting sync to OneDrive there is no other control of where Joplin should be looking.

In addition the resources on C: are taking up 2.7Gb while on F: 2.79Gb. This means they are mostly duplicated but not exactly. Could this be a bug?

And here I have been able to find a file (that shows on all devices) and is in folders on both drives.....

here is a file that is only on the F: (OneDrive folder and doesn't show in Joplin on the PC

FIle in the SyncTarget only for syncing, the files in the profile folder is for the app for working/offline use.

Please enable the debuging on the device where the files are missing and post both logs.
https://joplinapp.org/debugging/

Thanks Jack, however in the meantime I have gotten Joplin working again on my desktop install, this was achieved by removing Joplin completely and then re-installing in new folders. Then after a 6 hour+ sync all is good.

Therefore I have no idea what caused this and given my install is over 10000 records and was at least six months since original install, I'm may never know.

I must say I'm not happy to see that even although I have installed Joplin on F:, Joplin is still storing the bulk of my resources on the boot drive which is limited for space.

F:\User-f\antonvs\OneDrive\Apps\Joplin\resources 275Mb
C:\Users\Anton.config\joplin-desktop\resources 2.931Gb

Is it not possible to set Joplin up so that it doesn't store anything on the Boot drive?

The Data is stored in the User prifile from Windows.

You have several options:

  1. Change Userprofile Folder in Windows
  2. Use -userprofile switch from Joplin
  3. Redirect the ~\joplin-desktopfolder

The Option 2 is a not supported way, I would recommend option 3.

Steps for Option 3

  1. Close Joplin
  2. Create a Backup of C:\Users\Anton.config\joplin-desktop
  3. Move C:\Users\Anton.config\joplin-desktop to F:\User-f\joplin-desktop-profile
  4. Open command promt
  5. Execute the floowing cmd mklink /D C:\Users\Anton.config\joplin-desktop F:\User-f\joplin-desktop-profile
  6. Start joplin

Now your Joplin profile is stored on F

1 Like

Or you can use Joplin portable, then all your files will be right next to the .exe itself.

2 Likes

Thank you for that, I will give it a go tomorrow.

That seems a good suggestion as well. I wonder if I would have to do a new sync.

Also, down the track will having the portable version not be the same as the desktop version or even not supported?

You can copy your existing profile to JoplinProfile dir next to the .exe.

I am not aware of any plans to drop the support of it.

Btw one downside of using portable is that to update you'd have to manually download new version and copy the file.

Thank you so much. Have to say this is a brilliant solution.

I made a zip of my old profile then uninstalled the standard Windows installed version 2.4.9 .
This left 2.9Gb of files in C:\Users\Anton.config\ folder, which I manually deleted.

Then I installed Joplin-Portable 2.4.12 (prod, win32)
into a stand alone folder on my F: drive and unzipped my old profile folders here. Works perfectly with full sync happening between my 2000 odd notes (see below) and my iOS and Linux devices via Onedrive.

Leaves me wondering why this isn't the preferred installation method. Simple to maintain.

Cheers Anton.

Client ID: xxxxxxxxx
Sync Version: 3
Profile Version: 39
Keychain Supported: Yes

Revision: b45585d

Attachments
Not downloaded: 0
Downloading: 0
Downloaded and decrypted: 4727
Downloaded and encrypted: 0
Created locally: 3
Error: 0
Sync status (synced items / total items)
Note: 1986/1986
Folder: 762/762
Resource: 4730/4730
Tag: 81/81
NoteTag: 967/967
MasterKey: 0/0
Revision: 2147/2147
Total: 10673/10673

Conflicted: 0
To delete: 0

I have run into a snag and I thought I had a solution but that hasn't worked.

The transfer over to the Joplin portable went smoothly and initially sync went smoothly but then Joplin started resyncing thousands of files. Then OneDrive started having sync issues then sea-sawed back to Joplin until I was forced to switch off the safe option and wham, I was left with zero records.

I thought that the problem may have been that I hadn't let OneDrive resync after downloading the profile zip file (I should mention that I have the portable version of Joplin installed within a OneDrive sub folder on my PC's F: drive).

I again deleted the new profile and restored the zip again. Then I waited for the OneDrive sync to finish before opening Joplin again. As soon as I do this and start Joplin, all my notes and folders show until I try a sync, then I get the sync error as listed below.

2021-10-14 15-26-35 cc1

My big question is how do I get Joplin to recognize the profile without wanting to delete everything. I note that there are .json files and know of an app that works with other software and will do a rescan of an installation if the .json file count is out of wack and wonder if this is what is happening here.

Would appreciate some more help here as I am down a shaky road at the moment.

Maybe you could try just starting from scratch -- keep the zip as a backup, delete the profile, set up Joplin portable, and let it sync fully?

You may be right, but I had started from scratch with the full version a couple of days ago and it took six or Severn hours. Strange when I first tried the portable version, it synced OK. However this may have been because I still had the full version installed (but not running in the background) and I think the portable version must have been somehow interrelated.

I will take your advice and start from scratch and see what happens.

Now on further reflection, it is no longer a straight forward option as I no longer have the Joplin data on OneDrive. It now only resides in a zip of the original .config folder from the now deleted full version.

My other option is to re-install the full version and place the contents of the zip file back into the .config folder. But then I don’t have a backup of the orinal install on my F: drive and from memory they are different i.e. the resourses on the install drive have extensions whereas the don’t in the .config profiles files on the C: drive, at least the resource files don’t at least.

I wonder if I have lost my ability to recover Jopin at all. The closest I get it a fresh portable install and an unzip of the full version profile. All my records are always seen at this point but sync fails.

I really just need a way to tell Joplin-portable to just use the existing data.

Back to the Portable version. Up to now when I have tried installing with data from my zip backup I have been deleting all the files in the JoplinProfile folder first. Now I am trying by just overriding these files/folders to see if that makes a difference.

A bit more thinking has me now wondering if the root of my current problem is that I am trying to run Joplin-Portable in a folder that resides within that part of the F: drive that is synced to OneDrive. So is my folly that Joplin-Portable should not be run within a cloud drive. Hence syncs within syncs may be trying to take place.

I will now try installing Joplin-Portable somewhere else on the F: Drive.
Question is will Joplin-Portable then automatically create its own sync folder within OneDrive?

Hopefully I'm on the right track now. I have moved the joplinportable.exe file to another place on my F: drive and ran it as a new install.

This created the JoplinProfile folder structure next to this install (as it should, see screenshot below).

I then ran a new sync to OneDrive. This created a Joplin folder structure under F:\User-f\antonvs\OneDrive\Apps\Joplin (as it should).

My thinking now is that if I now extract my zip backup into this folder I may have success as the data will then be in the correct place away from the .exe and in the OneDrive sync folder. Wish me luck.

Or are the structures of the full version and the portable not compatible?

Here is the structure of the full version backup I have zipped:

While this is the structure of the portable version.

I don't se that they are compatible. For a start the full version appears to store its data in an SQLdatabase whereas the portable version just has a MD files.