Joplin Deleted all my Resources?

Yesterday, I was quite shaken to notice that none of my resource links were working. Joplin reported the resource non-existant. I looked into the ~/.config/Joplin-Desktop folder and found that indeed, all but a few of my resource files were gone!

Fortunately, I was syncing my Joplin instance, and my backup (Samba Fileshare folder) was unneffected by this. I was able to clear my Joplin data, reinstall Joplin, and sync from target and get it restored. phew!

I just wanted to report this, as the devs may have a better idea of what happened, and how it can be avoided/fixed.

Here is what happened:

  1. I think it may have occured when I uploaded a couple large .zip archives as resources (Drag n' drop, 500mb -ish).
  2. I didnt notice any issues immediately, but later (hour or 2) tried to open a different attachment, and literally nothing happened. I was in the middle of an important Lab report with a fast approaching deadline, so I just re-downloaded the file from University resources.
  3. The next morning, (Computer power cycled) I found that no links worked. They all reported the file at path didnt exist. I checked, and those resource files were indeed completely gone. Not it recycle bin either (Windows).
  4. I backed up by backup, Uninstalled Joplin, deleted Config and data folders for Joplin, Reinstalled, synced with Samba folder. All was Fixed!

OS - Windows 10 Home
Joplin - Desktop v1.2.6

Since recovering my data, I have setup rsnapshot for biweekly backups on my Samba Joplin sync folder... That was just too scary to almost lose 25 gb of well organized notes and resources.

Is it possible that the resources were deleted from the sync target? What do you think with?

I was able to completely recover my resources (and the rest of my notes) by clearing all Joplin data on my computer and syncing from my Samba share. So the Samba share had a complete copy. I currently only have 1 device (my computer) that I edit notes on.

Im not sure I understand your question @laurent

Im not sure I understand your question @laurent

Yes sorry, I don't understand it either :slight_smile: I must have written that quickly and didn't read myself back.

What I was wondering is perhaps the resources have been deleted on the Samba share, to save space or something, and then have been deleted locally via sync. But you confirmed that's not what happened.

Is it possible that the Samba share sometimes fails and makes it look like the file are not present even when they are?

Yes, I guess that would be possible. Its not a highly reliable system (Raspberry pi + Hard-Drive).
Would that cause a full loss of the data? Also, wouldnt that also delete the notes themselves?

Only the resources were missing. All of the actual notes were still there, just tha attached files were lost.