Lost line spacing formatting upon Evernote markdown import, any fix?

Operating system

Windows

Joplin version

2.14.20

What issue do you have?

Hello.

I moved my files to Joplin via Evernote by importing ENEX files using the "Evernote Export File (as Markdown)" import option. Unfortunately, I have noticed that my line spacing formatting in my imported notes has all vanished wherever I had triple or quadruple or 5x, etc line spaces on the Markdown and the WYSIWG sides of Joplin. See screenshot where I directly copy and pasted an example from Evernote into the Markdown editor and how the WYSIWG editor completely ignores my triple line spacing section.

I looked around online for a fix and tried different import methods. If I import "Evernote Export File (as HTML)" then the extra line spacing is preserved but the WYSIWG editor font type and font size mysteriously reverts to the program's default instead of my custom font type and font size I put in in userstyle.css.

I fear there is no solution to this and I will have to use a totally different program than Joplin in order to keep my triple and quadruple line spaces in my notes, but I was just wondering if anyone knows of a solution to this issue as a hail mary (last resort) attempt. Thank you.

Screenshots

@superphily welcome to the forum.

If you import your Evernote notes as Markdown they are as best as possible converted to Markdown and the Joplin note type is set as Markdown. The CommonMark spec for paragraphs states that, "Multiple blank lines between paragraphs have no effect". That is why when Joplin creates the rendered view of the Markdown it collapses all the blank lines into one. So this occurs because Joplin is displaying Markdown as per the Markdown specification.

You can however use </br> to force additional empty blank lines.

image

I believe that if you import as HTML then the Joplin note type is set as HTML and the import brings in as much HTML code from your Evernote note as it can. It does not convert to Markdown. Being HTML, if no font settings are defined in the HTML for that note you get the Chromium browser default which, I believe, is a serif font. Also being an HTML note, not a Markdown note, means that userstyle.css will not work because Joplin is not converting Markdown and adding the css to then display the note. Joplin is just displaying the HTML in the note as imported. At least that is how I understand what happens here. I am not a user of HTML notes. Anyone please correct me if I am wrong!...

1 Like

Thanks so much for explaining.

Huh, I suppose then for existing notes I will just use Word or another program since reinputting additional empty blank lines by hand would be a lot of work.

So, if I input additional blank lines using SHIFT+ENTER or ENTER in WYSIWG will it stick? I did a small test and it appears to stick if I input extra blank lines in WYSIWG, though inputting them in Markdown doesn't work at all as you explained.

I've noticed that all my underlining in my notes is gone too. That is just the way Markdown works?

Sure. I think that all that SHIFT+ENTER is doing is adding a <br> rather than a <p>.

Adding </br> (or <br>) to an empty line in a Markdown note in the Markdown editor should add a blank line to the rendered Markdown.

Underlining is an enhancement to Markdown that has to be enabled (Tools > Options > Markdown > Enable ++insert++ syntax (wysiwyg: yes)). I am guessing that it would have to be enabled before importing, assuming the importer will actually take this option into consideration when importing the ENEX HTML as Markdown. I cannot test as I do not have an ENEX file.

1 Like