Links to embedded files don't work in WYSIWYG

Operating system


Joplin version


Desktop version info

Joplin 2.13.11 (prod, win32)

Client ID: 98e03581a9004e72af43d3dce8854350
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 6670f9a

Favorites: 1.3.2
Note Tabs: 1.4.0
Simple Backup: 1.3.4

Sync target




What issue do you have?

At some point links in a note (PDF, Zip, etc.) don't do anything when Ctrl-clicked in the WYSIWYG editor. Over a year ago, I imported everything from Evernote. Originally, the links opened the document or file. If I switch to the markdown editor, the links work. Links to web pages do work in the WYSIWYG editor.

In the past two days, I had to do a fresh reinstall of Window 10, and reinstall all of my programs. I installed the latest version of Joplin and synced with Dropbox. Encryption is on. After everything synced and decrypted, I tried the file links again. They still don't work in the WYSIYWG editor.

See the attached screenshot. A simple click on the link in markdown mode opens the PDF. No combination of clicking (or right-click and Open) will open the PDF in WYSIWYG mode.


Tried 2 minutes ago, with Joplin 2.13.9, absolutely no problem with links in either editor.

Did you import all your Evernote notes as HTML rather than Markdown? That code looks very messy.

Try creating a new note with the below as the link and see if it works in both editors.

[CompTIA A+.pdf](:/6782df27c34d44d7b7367251b9a91d09)

Check the long number in brackets is the same as in your original note. My eyes have trouble copying long hex strings!! :slight_smile:

Yes, I did originally import as HTML. Your suggestion works in both editors.

However, as I said, the links used to work in both editors. I'm not sure when things changed. It's the same notes as before.

I really don't want to go through hundreds of notes to manually change the code. Evernote is long gone, so I can't re-import everything.

After trying to open the link in the Rich Text Editor, when you go back to the Markdown Editor is the href="6782df27c34d44d7b7367251b9a91d09" bit still there or has it been replaced by href="#"?

I only ask as this seems to be possibly similar to, but not quite the same as, this bug which it appears has been fixed for an imminent release.

It's still there.

The new version 2.13.13 fixed this. My attachments open again in the WYSIWYG editor. Thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.