Line of tildes causing following text to render as a block of code

Joplin version: 2.1.8 (prod, darwin)
OS: macOS 11.4

Hi, I recently started using Joplin on macOS. I've imported a lot of existing notes from a different application. I tend to use a separate line of tildes (e.g. "~~~~~~~~~~~~") as a division between sections of my notes. However, Joplin seems to be interpreting this as the beginning of a block of code.

I can't seem to find anywhere to disable this behavior, and I haven't noticed any documentation that this is intended behavior (and I thought blocks of code would normally be started with a sequence of back-ticks (e.g. "```"). Anyone know if this is a bug or is intended, and is there any way to change or disable this behavior? Thanks!

Hi @ragthyme (nice name btw), i was also confused about this so decided to look in to it. Turns out that it is a part of the common mark spec which Joplin (mostly) follows.

The markdown standard for horizontal lines is --- or ***. Both of these work and will be better supported.

As far as I know, there isn't a way to disable this behaviour. I imagine that you could create a plugin that changes the Joplin renderer, but you'd need to be desperate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.