Limit line length in md + wysiwyg/view

Hi there, I'm new to Joplin and am running 1.8.5 on Fedora 34. I was wondering if it's possible to limit the line length, preferrably for both the MD editor and the wysiwyg-editor/viewer(as I understand it). Every line can be ended via the soft and hard options but it would be nice to make the text autowrap at some point and not fill my 32" display horizontally. (Have been using Onenote via a browser for a couple of years but it can get strangely cpu intensive when moving the cursor quickly and tends to forget autoformat settings and in general is significantly inferior to the win10 experience; still the canvas can be nice and the set-a-width-for-this-paragraph definitely is); or like Obsidian's "Readable Line Length"(Obsidian is also a bit of a hog comparatively speaking when compared to Jop).

Cheers for any hints

I do this for the markdown editor using the below CSS in the userchrome file

.CodeMirror-sizer {
  margin-right: auto !important;
  margin-left: auto !important;
  max-width: 800px !important;

I'm not sure about the WYSIWYG editor, but it will likely be similar.

Thanks! I created that file (.config/joplin-desktop/userchrome.css) and entered the css you provided. Then started Joplin and I didn't see a difference, not in the MD editor and not in the wysiwyg so I opened the settings, appearance, advanced- 'Custom stylesheet for Joplin-wide app styles' and the newly created css file opened so Joplin should be aware of it.
(it's a flatpak)

The Flatpack installer is maintained by a third-party and is not an official installation method. Unfortunately, this means that some instructions will differ when using it but we have no control over the flatpack version so it can't be helped.

Thanks! If I don't find something in the official repos I tend to look for a snap or flatpak but shall henceforth pay more attention to products' homepages and AppImages. I tried the official AppImage and it picked up the flatpak's settings and notes and the max width is affecting the MD view. Thanks again : )

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.