JoplinPortable can't update to latest version of plug-ins

I am using JoplinPortable.exe from a USB stick that travels to different computers. On 3/3 computers, I am unable to update to the latest version of a plug-in.

When I try to update to later versions of the plug-ins, I get this error message

My work-around is to delete the plug-in and then add it again.

Joplin 2.4.9 (prod, win32)
Client ID: f26539edb5dd40f8a346af9247bd6a41
Sync Version: 3
Profile Version: 39
Keychain Supported: No
Revision: bb44c4e

What am I doing wrong?

Do the /tmp and /plugins directories exists on the USB key? Could it be some permission issue? For example, you install the plugin on computer 1, so the folder gets the permission setup on that computer. Then when you try from computer 2, the permissions are different.

I set READONLY attribute on both /tmp and /plugins

without restarting:

I get the same message after shutting Joplin down, then starting JoplinPortable.exe up.

Right, but if you make it readonly it can't work as the app needs to write to these directories.

Sorry, I meant to write that I reset the READONLY attribute flag to off, meaning that writing is enabled on those USB directories. A restart of the app doesn't seem to help.

Joplin 2.5.1 (prod, win32)
Client ID: 67a5658fc1484adf927f4bd6f8e8a8dd
Sync Version: 3
Profile Version: 39
Keychain Supported: No
Revision: b6b972b

Win10 Pro x64 21H1

@markrenier it does not appear to be your setup or flash drive.

I just tried to update a plugin (using 2.5.1) to see if I could duplicate the error and I can.


Apparently EISDIR means:

... that the target of the operation is a directory in reality but that the expected filetype of the target is something other than a directory.

Also I notice that the second path shown does not look like a valid path for Windows (forward slashes)


Could not install plugin Error EISDIR illegal operation on a directory

Just adding these keywords as so far the error has only been posted as an image. If anyone searches for this error this post should now show up. (Whether they bother to search the forum is another matter!!)

Ok looks like it's a bug in the path then. @markrenier, would you mind creating a bug report on GitHub to keep track of this?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.