Joplin Syncs but desktop can't "see" Android notes and vice-versa

On Android, I'm using Joplin 1.2.6 on Android 9, while on Windows 10, I'm also using Joplin 1.2.6 (win32). On Linux Mint I do not know the version number as I do not currently have access to the computer but I suspect it's the same version as I installed them all on the same day.

I set them up to sync unencrypted via OneDrive. The notebooks on the Linux and Windows computers can be seen on one another and sync without any issues. However, the desktop computers cannot see the Android notebooks and vice-versa (on Android, I can't see the desktop notebooks).

However, I know that they are syncing with OneDrive because if I make a change on Android, and then force a sync, I can see in OneDrive on the Windows computer that a new file is created in the OneDrive-Personal/Apps/Joplin folder, appropriately time-stamped with the current time.

I have uninstalled and reinstalled the Android Joplin multiple times and also Cleared the Cache and Storage a few times before reinstalling but it doesn't help.

As I have not actually put in any real notes into the app, so there is no problem if you need me to delete all the data/notes/notebooks.

Although I tried to look online for an answer, none of the answers seems to apply to my situation.

Can anyone please tell me what I should do? Thank you for your help.

1 Like

On your Linux/Windows system do you set up OneDrive Sync in Joplin or File System and you selected a folder from OneDrive?

I setup as OneDrive Sync on both desktops.

I checked and the version of Joplin on my Linux computer is 1.2.6.

Joplin for Desktop

Copyright © 2016-2020 Laurent Cozic
Joplin 1.2.6 (prod, linux)

Client ID: ce6f4e3f770a4e0ebc642adfcfaa0dac
Sync Version: 2
Profile Version: 34
Keychain Supported: No

Revision: f5f117c (master)

I'm using Linux Mint 20 Cinnamon v4.6.7

Any help would be much appreciated.

Cleared Storage and Cache on Android, deleted all notes on Android, Linux and Windows. Uninstalled on Android and desktops. Deleted Apps/Joplin folder on OneDrive. Reinstalled on Android, Linux and Windows. Problem remains.

No problem between Linux and Windows desktops but neither can "see" notes from Android and vice-versa.

Can anyone help, please?

There's not nuch we can do without debug logs. A lot of people synchronize with Android, including me, and all works splendidly.
I suspect there's an issue with your Android, but we won't be able to be more specific unless we have proper logs.

Is this what you need?

I am actually switching over to using WebDAV on Box and that seems to be working but I'm still in the process of switching over.

syncReport-1604301025766.txt (108.6 KB)

Yup, I can now confirm that Joplin is syncing just fine on all 3 devices (Android, Linux and Windows) via WebDAV on box ( No idea why it couldn't sync properly on OneDrive.

But if anyone can figure out and solve the problem with OneDrive that would still be great cause I'm sure others will be able to benefit from it.

Thanks to everyone who tried to help.

Oh yes, if anyone else is interested to sync with WebDAV on Box, the link below will be useful.

To keep things neat and tidy, I would further suggest that you create a folder named Joplin in the root of your box file system and use the following url rather than the one stated in the link above.

You can replace Joplin with any other name that you may fancy.

1 Like

Yes, this helps, but maybe we also require a debug log from Android. The current log shows that files are synced, but I don't see any errors.

Let's wait for Laurent's input. But I'm glad it works with WebDAV.

People are using OneDrive without issues and even support was added for OneDrive for Business.

Sorry, it took me quite a while to get the Bug Report from my phone. Not only that, when I tried to upload the Bug Report, I received an error message that the file was too big (5,713 KB) and the limit was 4,096 KB.

Hello, I have the same issue.
I am also using the desktop application from Ubuntu, windows and 2 Android devices, all on the same onedrive
Here are the debug logs from android device
syncReport-1626097060439.txt (47.0 KB)

This has something to do with the issue perhaps

"""Sync: createLocal: remote exists but local does not: (Remote""

Same proble except I am syncing to file system (another.programm syncs my cloud storage with windows Ubuntu 21.2 and my android phone). The files all sync perfectly and Joplin picks them up on windows and Ubuntu....but not on Android. Previously I was using WebDAV and it would showed synced without displaying any of my notebooks.... Now the files are present on the device but Joplin doesn't succeed to display them
syncReport-1648910563410.txt (29.0 KB)

If only Joplin would sync flawlesslt or offer a few GB of free note storage online... and stylus support would really be beat onenote by far....those features would probably come in the next 10 years or? XD

File system sync has been broken on Android for some time, see Android filesystem sync is broken after 2.6.3 update · Issue #5779 · laurent22/joplin · GitHub