Joplin sync with nextcloud... or not

Hi this is might not be a bug but I have spent a lot of time looking for an answer and couldn’t find any. I don’t know what to do. All i want to do is sync notes on my android 7.1.2 run phone and my Windows10 run computer with open apps and software.
Apparently the answer is Nextcloud on my computer, Joplin on my phone so i have created an acount on Next and dowloaded Joplin 1.0.310 on my phone. First i created a Nextcloud acount but it is called Hostiso which is confusing, (could it be part of the problem ?) When i go into Joplin sync settings, i swith the default “Dropbox” to “Nextcould” and i enter the Webdav adress i found on hostiso https://us.hostiso.cloud/remote.php/webdav/ plus nextcould id and password. It says that it seems correct but nothing happens and when i exit then come back to the sync settings, everything i entered has been erased and the sync target has gone back to the default “Dropbox”. This might be a newbie question but i am a lost and frustrated newbie. Could someone help me with this please ?

–>

Nextcloud is a server that you need to host yourself (it’s a PHP app). Hostiso appears to be someone who has made an instance of Nextcloud available to the public.

That webdav URL could well be right!

However, you’ll need to go to your settings in Nextcloud (Hostiso nextcloud), then Devices & Sessions, create an “Create new app password” and then user that password alongside your usual username in the app.

Also - when you’ve set everything up, clicked the “check sync settings” button, go to the top of the screen where there’s a Save icon (floppy disk symbol). If you don’t do that, the settings will revert to their previous (I’d argue that’s somewhat bad design, as it’s inconsistent with Android apps more generally).

As an aside, I’m not entirely sure about Hostiso - they’re just someone who happens to be running a Nextcloud instance which is open to the public (for some reason). Be sure that you understand it’s not the Nextcloud developers running that service, and that it’s another company that you’re trusting with your data (their about page might help fill you in).

Make sure you press ok or Apply to save the settings.

Hi, just to explain how I set it up? First (like naxxfish also explains) I looked up a Nextcloud provider, in my case Webo hosting (https://cloud.webo.hosting/). Sign up and get 5gb free Nextcloud space. Then I created a directory ‘Joplin’ in Nextcloud. That is step one. Now you can open the Joplin app on your phone and go to Joplin - preferences - synchronization. In that category you find two items for this: 1. Nextcloud WebDAV Url (in my case https://nextcloud.webo.hosting/remote.php/webdav/Joplin) and 2. fields to fill in your Nextcloud username and password. Click the button ‘Check synchronization settings’ and it should work. From now your notes are synced to the cloud and then to all devices (in my case a Macbook, Android phone and a Manjaro Linux PC). Happy Joplin’ing!

It might not be obvious but after you click "Check sync config", your settings aren't saved. You need to click "OK" or "Apply" for this to happen. It sounds like you didn't do that based on your previous post.

1 Like

Thanks for the addition, Laurent!

I had the exact same issue. In this context I don’t think that is the least unexpected behaviour. In a desktop app, having an ‘Apply’ button is kind of fine (they have been around for a long while) - but mobile apps settings pages don’t tend to work that way and users don’t expect to need to press something to ‘commit’ to settings. Certainly on Android jetpack and you’re using Preference then this happens automatically.

Originally the settings were saved automatically, but the problem is that some of them work as a group. In particular for sync, you don’t want it to auto-save until you entered both the username and password. You also don’t want to auto-save while you’re still typing (so even if there was no save button, there would have to be a button next to the field so that the user can tell they finished typing their username or password).

Maybe the issue is to make the Save button more visible. Maybe by chancing the colour or making it blink.

What about making it save if check sync succeeds?

1 Like

Hello, thanks a lot everyone for all this information. I would never have guessed i needed to touch the floppy icon to save my informations. I would have expected a button in the bottom with"save" written on it or something like that. But first things first, going back to naxxfish post. I didn’t intend to create a Hostiso account, it’s the Nextcloud website which had me create it when i chose Download for desktop/Windows… on their website. How do i work only with nextcloud ? Should i choose instead “Server packages / for self-hosting on your server” with only a PC and little computer knowledge or something else ?

The main use case for Nextcloud is not giving someone else access and/or control of your information. So, I'd avoid any Nextcloud app providers like the plague. Set up your own instance of Nextcloud either on your own hardware, or cloud computing host (just the computing, no applications as a service ) such as DigitalOcean, Linonde, AWS, etc.

There are tons of guides out there for each option, so follow the one for your selected installation method.

I've found that WebDav permissions are the usual culprit to syncing issues. Check that your joplin user has file , folder, and application-level permissions to read and write files.

The URL you are using looks to be in the correct format, keep in mind that you may need to change the port if you are using non-default port.

Another tip, is to use the curl command to test the URL. you can also send credentials with the curl utility , so first try not logging in, then with logging in. But only after checking permissions( see above).