Joplin Sync using File System

Joplin 2.7.13
MacOS 12.2.1
Windows 10

I installed Joplin on my windows machine and created a sync folder on a mounted file share. Works great.

I installed Joplin on my Mac and pointed to the same sync folder on the mounted file share. I accidentally over-wrote the file share with from the empty MacOS Joplin. I restored the lost files on the file share and verified that the Windows machine can sync. Now, on my mac I keep getting a sync error about a file in the lock folder not found (see below)

Completed: 07/03/2022 22:50 (1s)

Last error: Error: Error: Error: ENOENT: no such file or directory, open '/Users/jjj/Amazon WorkDocs Drive/My Documents/Personal/X1/Joplin Sync/locks/1_1_5988ca5cd6d34cb28090c63570266237.json'. Path: /Users/jjj/Amazon WorkDocs Drive/My Documents/Personal/X1/Joplin Sync/locks/1_1_5988ca5cd6d34cb28090c63570266237.json. Path: /Users/jjj/Amazon WorkDocs Drive/My Documents/Personal/X1/Joplin Sync/locks/1_1_5988ca5cd6d34cb28090c63570266237.json

The file does not exist and I can't find it to restore it. I deleted the app on my Mac and the Joplin folder in the user library but every time I reinstall the app on my mac it is "finding" my sync config and adding it back to the Joplin app. How do I clear the reference to this lost file?

Welcome to th forum!

I never used the Joplin Mac app. But on a windows system I would try to follow this path:

tools—> options-> synchronisation->Advanced settings-> Button: Delete local data and re-download from sync target.

I suppose this will reset your sync history/config to enable a fresh start.

But please read the instruction below the button carefully before pushing it!


I have tried that and still get the error. Thank you for the suggestion

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.