Joplin not connecting to Nextcloud

Operating system


Joplin version


Desktop version info

Joplin 2.12.19 (prod, linux)

Client ID: 104591ac692448f2beb802c50d678f1a
Sync Version: 3
Profile Version: 43
Keychain Supported: No

Sync target


What issue do you have?

Hello Joplin Forum,

I recently installed Joplin on my laptop running Linux Mint, after having used it successfully on my MacBook Pro. However, when completing the necessary information for syncing with my Nextcloud server (which worked with Joplin on my MacBook Pro), I keep getting the following error:

Error. Please check that URL, username, password, etc. are correct and that the sync target is accessible. The reported error was:
request to https://[server info]/ failed, reason: connect ECONNREFUSED 2606:4700:3034::6815:375:443 (Code ECONNREFUSED)

I triple checked all my server information and even tried using the WebDAV sync option instead of Nextcloud. All gave me the same result. I searched through the Joplin GitHub Issues and this Forum before creating this post. I am stuck and not sure what to try next.

Any help would be most appreciated.

Thank you.


I am sure you agree, something is wrong. But triple checked doesn't seem to cut it.
So back to the basics:

You may have expected / used but not the email inside.
some other nextcloud providers do NOT require this

  • is the end of your url ~/Joplin or ~/Joplin/ ?
  • check the cloud documentation, the nextcloud app (for settings) and Joplin docs
    It takes a little patience, but you can figure it out !!

I suspect ipv6 may be the issue, can you try with ipv4?

About a month ago I had issues setting up a sync to Nextcloud. I am running LM also, but i tried syncing with the Android app and it also didn't work. So, maybe it's related to the server setup. I look forward to hearing how this problem is resolved.

Hi @roman_r_m,

It seems I am running ipv6 and ipv4 simultaneously. It does look like ipv6 has given others problems as well:
Priority of IPv4 and IPv6 addresses in Linux version?
Connecting Joplin to a IPv6 sync target
Joplin sync failure on IPv6 only networks
Joplin sync failure on IPv6 only networks

Of note, however, I was able to sync Joplin after disabling my VPN (I use Private Internet Access). Although, after reactivating the VPN, my sync configuration check produced the original error again. I can still sync Joplin while running my VPN without issue on my iPad Pro, MacBook Pro, and even another laptop running Linux Mint.

What do people think?

Any further ideas or recommendations are highly appreciated.

Thank you.

Hello all,

I recently updated my Joplin install to the following:

Joplin 2.13.8 (prod, linux)

And I am happy to say that the initial issue is no longer occurring and I have been able to successfully sync Joplin on my Linux Mint laptop with my Nextcloud server and across my other devices.

In conclusion, it looks like whatever was preventing my Joplin notebooks on my Linux Mint machine from syncing with my Nextcloud server was fixed in the most recent update.

Thank you for your help and input.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.