Joplin is completley unresponsive

Today joplin on my laptop has become completely unusable.
I am using encryption on onedrive, have the macos theme and the eztable plugin.
The first time I tried starting it it was stuck on decrypting forever. I didn't change the password. Checked that I am using version 2.9.17 on Windows 10.

I tried using safe mode, but all the toolbars, buttons, whatever do literally nothing and I have no idea where the "profile directory" is supposed to be.

I don't know how to disable the theme and plugin because nothing from the debugging tutorial works.

I have tried reinstalling joplin and all it did was break all the icons.

When joplin is open it just sits there unresponsive (not "not responding", just frozen) and uses about 20% cpu (much higher than normal) constantly.

Every folder says ":key:Encrypted" and it says "Some items cannot be decrypted"

Is there any way to repair it or is nuking joplin (which I'm also not sure how to do) the only option?

(Off topic: I tried 4 different emails to sign up for this with email, none of them received the confirmation
email for 40 minutes. I gave up and used github.)

What plugins are you using? And is there any warnings or repeating messages in the console?

I'm using macos theme with eztable, table-formatter and markdown-prettier.
I don't see anything that looks like an error apart from safe-mode being an unrecognized option.

People reported issues with the macOS theme. Does it work better if you disable it?

1 Like

I removed the theme from the plugin folder and it seems to be working again. "Some items cannot be decrypted" went away after retrying. I added the theme back and it appears to be working again. The theme was out of date.

Should this theme be avoided?

I didn't develop it but it seems to have issues. Maybe the developer fixed it in the most recent release

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.