Joplin in NAS Synology (webDAV)

This helps me a lot. Silly question but is the ***** in https://***** stand for the quick connect address? Also how do you find your experience using WebDAV? TYIA!!!

Yes, that’s right.

webDAV on the Synology NAS works very well. I had problems with Dropbox and Onedrive, but the NAS is quite smooth.

I also set up NAT loopback on my router so that when I’m on the local network it’s not going out to the internet and then back when syncing.

1 Like

So if my quick connect is bob, then the address would be correct?
How do you get yours to work on the mobile Joplin app? Being trying for the last couple of days with port forwarding and all, just keep getting “network request failed”. Did you have to get any certificates for it work? Did you set up your router through synology external access? Sorry for all the questions. Can’t find a specific answer anywhere lol

Has been working great on desktop though lol. Was using Resilio sync before this so I was able to just enter the direct path for the folder I was using. http://[local IP address]:5005/homes/username/Joplin/

Thank you!!

1 Like

Yes, that’s the format of the address I use. I’ve got a certificate from LetsEncrypt, which I think I needed for Joplin on IOS but not on Android. There was a useful video somewhere showing you how to apply and install the certificate. It gets renewed every 3 months.

Your desktop direct path is going to a folder under your username, which is under home. However, my webDAV folder, just called joplin, is top level, and I think that’s what your WebDAV URL would be looking for. You could maybe try[username]/joplin/, or move the sync folder to be at the top level.

Also, have you configured the WebDAV server on the Synology NAS?

As far as the desktop is concerned, I used to use the direct path but I read, on this forum I think, that maybe that’s not a good idea because if the network connection goes down Joplin can act as if the sync folder is empty and will start deleting your notes. So I changed the desktop to use WebDAV too.


Hi I think there a bit of confusion here. It’s not the quick connect address from synology but the synology ddns you need I made this mistake last week


@williwinkie it worked!! wow. It didn’t occurred to me that I actually needed to add the hostname to DDNS under Control Panel before using it!! It worked almost immediately! Thank you everyone for your help!!

@laurent is it possible to add Synology to the list of WebDAV synchonisation? This is a great solution in my honest opinion.

So just to recap, and anyone can correct me if I’m wrong; to get WebDAV synchronisation working on a synology NAS:
1-Create a Joplin shared folder at the highest level in File Station.
2-Download WebDAV server from the Package Center.
3-Enable HTTP/HTTPS.
4-Under External Access in Control Panel, select Add under DDNS to create a registered hostname.
5-Under Router Configuration, select Create to add port forwarding rules for the ports used in the WebDAV server application (the default 5005,5006 were used in this case).
6-Go to your Router and open the same ports. In my case, I have a Lynksis router and it was under Security->Apps and Gaming->Port Range Forwarding.
7-Go back to Router Configuration under External Access and test the connection. Should result in “ok” in the Connection Test Result column.
8-I would suggest manually backing up your notes to the Joplin folder and to another folder on your desktop or a drive in case synchronisation tries to delete your notes.
9-Under the Synchronisation section of Joplin:
-use http://[local IP address]:5005/joplin/ for the desktop version
-use https://***** for the mobile version. In this case, this address needs to be the same one you created in STEP 4.
10-Enter the login credentials under WebDAV username/password for your Synology NAS.
11-Select “Check synchronisation configuration”. Should result in “Success! Synchronisation configuration appears to be correct.”
12-Now you can select Synchonise in the main tab and you’re done!


Seems to be an ongoing issue because of HTTP use verse HTTPS as Senior-Discount described.

I'd prefer not to have to create a self signed SSL cert and import them manually into my devices, so http is the preferred method at this point in time, security is not an issue since i'm VPN'd to my network anyway.

Thanks for this summary, Senior-Discount, it got me up and running with Joplin syncing to my Synology DS412+ NAS. Works great on my Ubuntu 19.10 desktop, both http and https, and also works on my ipad.

However…the Android cell phone is a different matter. The connection to the NAS does not work at all. Further, every time I test the connection, it deletes all my WebDAV data - urls, userid, password, and resets to Dropbox (which I have never used). After 4 times retyping all this data with my thumbs, I gave up.

From browsing the forum, it seems there are a fair number of issues with Android. Having said that, I love Joplin - I’ve been looking for a OneNote replacement for months now, and Joplin is it. Great product.

Any ideas are welcome.

Just discovering Joplin today and quite impressed to far. I really like its sobriety and lightness.

Well, the first thing I tried after installing the Win Desktop version was to configure the sync with a WebDAV server on my Synology, and try to sync my PC (on the LAN) as well as a second device (OnePlus 7 Android) though 4G (not on LAN). And there I finished here of course ...

So far, I only managed to make it work using HTTP (port 5005).

The make it work on the LAN, I just needed to:

  • Make sure that my Syno user (was not using Admin) was in the Admin Group and of course was granted Read/write access to Joblin directory.

And for my Android to work remotely, I just needed to:

  • Configure my router Port Forwarding TCP 5005 to my Synology 5005

Of course, that means that form my Smartphone, I am running thru the web completely naked and in heat...

I quite tried things around HTTPS (5006) but without success... and still wonder how som of you managed to do that.

Going back to my discovery of Joplin... Cheers


i have running Joplin without Problen on my Snology NAS with the following configuration:

Synology WebDav Server: HTTPS Port 5006
Synology Privileges: WebDav Server allow User
Synology Certificate for WebDav Server: Trusted Certificate like Lets Encrypt (No self-signed certificate)
Joplin Sync URL: https://<URL>:5006/<Share>/<Folder (optional)>


Thanks @JackGruber
I guess I'm missing the certificate part... I am not good at that. I'll dig.
By the way, the /User/Folder is your own choice, right ? Could have been /Folder only ?

Sure, you can use https://<URL>:5006/<Share>

1 Like

I followed most of the steps mentionned here, execpt the DDNS as for the moment I am testing Joplin (since yesterday :wink: ) only through my local server.
Basically, I installed and enable WebDAV on my Synology NAS, I granted access to the "http" user to the "Joplin" directory I created in the root folder, I used the defaults ports, I tested the connexion from the desktop app (running under Ubuntu 20.04), I tested the conexion (through the "check synchronisation button), which was successfull, but since then I have an error (and obviously sincing is not working) :
request to failed, reason: write EPROTO 61947996422152:error:100000f7:SSL routines:OPENSSL_internal:WRONG_VERSION_NUMBER:../../third_party/boringssl/src/ssl/ (Code EPROTO)

I have checked for hours for the answer, without success so far.
Any idea ?
Thanks for your help,

In your link you use the port 5005 with https, but in the default Synology WebDav configuration is 5005 http!

Please cange your link to http.

one letter mistake :wink: thank you very much. I made a step, but I now face a new error :
PROPFIND : Unknown error 2 (405): 405 Method Not Allowed

Method Not Allowed

The requested method PROPFIND is not allowed for this URL.

(Code 405)

I found out an authorisation issue on my NAS, I changed the configuration, and Voilà ! It is synthing.
Thank you very much !

This config works perfect for me. Only one issue on my Android mobile. My external access works with, but when I arrive home and my mobile automatically connects to my home wifi, the synchronisation doesn't work anymore. I have to turn off my wifi on my mobile to make the synchro work again. How can I change this so that also works when my mobile is connected to my home wifi ?

I guess this is kind of off topic but I run Joplin server on a Synology NAS inside a Docker image and it runs fantastically - super quick. WebDAV is slow as heck. If you can, give the Docker version a try, it isn't soooo technical and it'll be worth the effort in the speed of syncing, especially in the beginning with larger note sets.