Home / GitHub Page

WebDAV not work with last release of Android

Hi,
Since the last update of Joplin, I can’t sync with WebDAV.
I put a tcpdump on port of WebDAV but I don’t see any request … I try to remove and reinstall the app, but I have a same issue.
How I can have more logs on Joplin (Android) ?
Thanks.
Frédéric.

My release on Android 1.0.271.

I try with another application on same mobile “Cx Explorateur de Fichier” Version 1.2.0. And it’s works …

1 Like

I see an error , but nothing with tcpdump …


And it’s work with other and I see dialog with tcpdump :

On that log it looks like the synchronisation was cancelled? What happens if you let it run?

I don’t do a cancel. I can mesure the time between request and the error, if you want.

I’m having the same issue since a recent update. Synchronization appears to just hang, while the test connection button also just hangs

I don’t see any errors in my log, only the sync starting and then never going anywhere. I can copy+paste open and log into the webdav endpoint from my mobile browser at the same time without issue

Screenshot_20190618-093000

Same issue here. Synchronization basically times out and never makes a connection to my Nextcloud instance. I am able to connect to Nextcloud directly with their app and am able to sync with linux based app. Just seems to be Joplin WebDAV issue on Android.

1 Like

@laurent is there a way to get a more detailed message why the network request failed (apart from running an adb log session)?

This seems to be a not consistent problem. I am running 1.0.271 on Android 9 with Nextcloud. I don’t experience WebDAV issues

Just adding a “me too”. My logs look like the others posted here, though can grab anything else needed.

Thanks

Edited to add: uninstalled latest version, installed v1.0.261 and sync worked correctly.

Unfortunately no. This error message is as good as “Unknown error”. It’s basically when something quite low level happens in the network stack, so on our side it’s usually hard to know what happened. Sometimes it’s due to proxy, or some weird behaviour with the network stack (especially on iOS).

I confirm, it’s work with previous release.

1 Like

It seems that I have the same problem as others. Can’t sync to my NextCloud account. I’m using Joplin 1.0.271 on Android 9.

Adding a “me too.” There’s nothing obvious in the logs, either on the Android device or any indication in the nginx logs on the server to say we even tried to connect. Previous releases were working just fine.

Wondering if it might be a client-side name resolution problem, I tried changing to an IP address, but it made no difference. I also tried rotating passwords in case that might bump configuration, but again, no luck.

(Btw, I really like Joplin - such a wonderful replacement for the myriad of note-taking apps that I’ve used over the years!)

  • tim

If someone has logs or info on how to replicate the issue, we might be able to look at it, but otherwise it’s not possible to do anything. It seems for most people it works fine.

Do we have confirmed reports of WebDAV sync working on android with this release?

A sync report log is at

https://paste.ec/paste/iCEKIMkK#uns5zIp0d5uui3Mi7Z-2vrxvwo58cD1aziAXBwZTJ/b

if they help, but suspect not.

I also tried running through a proxy to see if we were getting out to the network at all, but nothing appearing in the proxy logs either. Will keep investigating.

  • tim

@timf, so it’s just “Network request failed” every time? I’m using Nextcloud, which is WebvDAV too, and it works fine for me. @tessus also said above that it works for him.

Yep that’s the error every time. I’ll see if I can setup a nextcloud instance here and see if that shows the same problem. Just tested filesystem sync, and that’s working fine (not surprisingly, but it’s another data point at least)

  • tim

by the way, for your webDav server do you use http or https?

There are quite a few recent reports about Network Request Failed on the React Native repo and at least some of them seems to be related to using http, because latest Android SDK blocks these by default: https://github.com/facebook/react-native/search?q=network+request+failed&type=Issues

1 Like