Home / GitHub Page

Joplin deleted all notes

#1

Platform: Windows 10
Joplin version: 1.0.140

I am currently not using the synchronization features, because I have not been able to get Joplin to sync with my Nextcloud install despite repeated attempts. I decided to figure it out later and set the sync options to:

Synchronization interval: Disabled
Synchronization target: File system
Directory to sync with: (empty)

Despite this, Joplin kept telling me it was syncing. Today it gave me a sync conflict despite not syncing with anything. I decided to try syncing it with something to get the conflict to stop, and went with my file system. As Joplin has been located on the C: drive, I set the sync location to E:\joplin. I pressed sync.

Joplin proceeded to delete every single note. And no, I don’t have a backup, because this was supposed to be the backup. There is no reason I would have suspected I’d lose EVERYTHING.

So. If my notes are still on my hard drive somewhere, and if I can put them back into Joplin, I would appreciate directions.

Win10 client ignores synchronization intervals
#2

I’m sorry to hear about your issues and I wish you the best in recovery but Syncing is not the same as Backup. If something is built into a software workflow then it is not a backup so no Joplin’s sync is not suppose to be a backup. This is why Joplin has a bunch of options for export including the JEX single file backup generator. (backups are recommended at least once a week for valued data or once a day for critical data)

This wont help with recovery but it might be possible to use the WebDAV syncing with Nextcloud if the regular sync isnt working. I use WebDAV and it works great though not via Nextcloud so this is more of a theory suggestion than a tested one.

#3

Hello @larissa and welcome!

Unfortunately, this might be the issue more of us ran into - when Joplin has some sync set up, and then you change the sync target and the new target is empty, Joplin thinks you’ve deleted everything from the sync target, so deletes all of your notes from your local instance as well. It’s not really a bug, though there were discussions saying Joplin should probably display a warning in a case like this. (And yes, this happened to me too :sweat_smile:, fortunately I export backups before experimenting like this.)

As for the recovery: have you tried checking in the Recycle bin? (I don’t really know how Joplin handles the deletions in this case.) Or maybe the Profile folder? Or if something didn’t get uploaded into Nextcloud after all? (It works well for me, but I have never used NC for anything else before or since, so I don’t know much about it.)

I realize you’ve probably tried all of those before, but nothing more useful comes to mind. :frowning:

#4

The fact that you didn’t switch the sync target, but set it for the first time and still lost data, leaves me rather concerned. This should not happen. Someone just opened an issue on github:

We will have to wait for @laurent to comment on this problem.

The only way I can think of to get your notes back is to use one of those undelete programs for Windows. Deleted notes are not moved to the trash. There are just unlinked from the filesystem.

#5

Yeah, uh, I would have appreciated a warning of some kind. Frankly, a big confirm screen saying “hey make sure everything is set correctly because this could delete everything if it’s not” is always a good idea.

I did look on my hard drive, and there are a bunch of .crypted files on my hard drive, in the C:\Users\USER\.config\joplin-desktop\resources folder. I have no idea what to do with these. I assume they’re the encrypted versions of my notes, but how do I decrypt them and put them back into Joplin? Plus there are only ~240 of them; I had about ~450 notes.

Plus, only one of the images I’ve saved (out of dozens) is still in the folder. I had looked in the folder before all this happened, and they had been saving in the clear, separately from the encrypted files.

Also, like in the issue @tessus linked, I didn’t change the sync target - all I did was type in a directory for it to sync with. Before that there was nothing there.

#6

I had the exact same issue as @larissa (sync conflicts on 6 notes even though I had no sync set up) and in an attempt to solve them set up local sync. Then all my notes and notebooks went poof. Well, except for the 6 notes with conflicts, they can’t be solved even now. But at least they didn’t get deleted, so some work was saved.

I’m guessing the lack of solutions in this thread means that they are gone forever and 10’s of hours of note taking went down the drain.

I will replace Joplin with another note app, but for the love of Gaia fix this so others won’t experience the same.

#7

While I understand your frustration and I totally agree that the problem with conflicts without a sync has to be fixed, I do not understand why someone does not backup their data. macOS has TimeMachine (I also use disk cloning SW every week) and I’m sure Windows has similar options. Maybe you love to live on the edge, but I learned many, many years ago that every piece of SW has the potential to mess up your data. If it is not an app, the OS itself is sometimes pretty good in vaporizing your data.

@laurent how is it possible that people are experiencing conflicts, if no sync method has been setup in settings?

#8

It’s not possible since by default it’s set to Dropbox but without auth it can’t do anything. Not sure what was the issue here, we would need more info.

#9

Ah the good old spot of victim blaming! Nice try.

Also, the the annoying bug with the conflicts is neither what’s the big issue here.

The app deciding that “when I have many files locally, and none at the brand new sync location, the correct alternative is to delete all local files. TADA! All is synced, I am a good program!”.

#10

Hmm, I can’t recall doing that, but since you brought it up: Some people are just too stupid to cover the basics. Still not blaming anyone, just stating a fact.
If you feel addressed by above statement, I reckon deep down there’s a bit of self-hatred and guilt. Therapy might help.

See what I did there? I can be a jerk too. And you know what, in situations like this, I truly enjoy being one.

It also helps to read the documentation and the FAQ, but I guess it’s easier to vent. I get it.

#11

This is a well documented issue and there’s a warning about it on the config page and an entry on the FAQ about it.

Joplin perhaps is not an app for everybody because it gives you a lot of flexibility, but you also have to be careful in some cases and understand what you’re doing (or read the doc, ask here, etc.), especially when doing major operations like switching the sync target (and especially when doing so without a backup).