Issue when importing the .md file from Dropbox


Very impressed with Joplin! Before migrating from Evernote I want to test recovering my notes.

I synced my jolpin files to dropbox with joplin encryption turned on and it synced fine.

I then installed joplin on a new machine (to test recovering) and imported the .md file from dropbox into joplin on the new machine.

However the import just shows as computer code instead of my notes. I have a feeling this is something to do with encryption.

Any ideas?


It looks like you selected import Md files and chose the import directory as your Dropbox directory, correct?
The files that are synched into Dropbox have the .md file extension but in reality they’re not real markdown files (as you can see). If you want to import markdown files using the import dialog, you will need to first first export using the same dialog.

Another alternative (to me this is the better one) which is more similar to what you’re try to do would be to set the sync method to filesystem, and select your Dropbox folder as the target, this should (I haven’t confirmed this) sync the files into your new Joplin instance correctly.

That’s right it’s only for syncing to files on your machine, I had assumed from above that you had Dropbox automatically syncing, if that’s not the case, what you probably want is to just regularly backup your Joplin data (via export).

Hi, and welcome :slight_smile:
Here you can set your dropbox folder if you want.

I made some progress but I still cant the sync to work well enough.

I downloaded the md files that were synced to dropbox to a new machine

However the files are individual files, not directories. I can only import them one at a time to jolpin which isnt feasible with thousands of files. Using the file system type sync option there is no option I see to sync directories, only individual md files!

is that correct?