I need to thank the developers but

I already have a lot of markdown files as notes. So how do I convert all those in a click to Joplin notes? This feature is not there and I need this feature please, converting all my markdown files to Joplin notes in my system with the same folder name and etc..

File, Import not work?

I still didn't try it in my computer and there is a power cut in my home but I have lots and lots of markdown files saved with a chrome extension to view markdown files so I need the option to import all files in just a click, with same directories and everything

Have you actually tried importing them? File -> Import -> MD Markdown (Directory) is designed to take your .md notes in a folder structure and apply that to the notebook->subnotebook->note structure in Joplin.

1 Like

I will try :+1:, when power comes, and I have Google Backup and sync in my phone, meaning I have all my drive files stored in my computer in my Google drive(phone). So is there any way that I can do this with the phone? No right

EDIT: Also when I import it as an entire directory what will happen to the other files than .md?

No, I'm pretty sure the import has to be done via desktop.
The import suggests it can accept *.md, *.markdown and *.txt files, anything else seems to get ignored.

To be clear, if you imported files as per the below folder structure:

Then you will end up with:

  • Notebook1
    • SubNotebook1
      • Note1
      • Note2
      • Note3
    • SubNotebook2
      • Note4
      • Note5
      • Note6
  • Notebook2
    • Note7


I tried that but when I dragged my desktop folder into the app but nothing happened. No new notes were created

Have you tryed the Import menue? I think drag and drop will not work for import.

1 Like

Im trying

Wow, it worked, thanks
I got all the directorues and sub directories.

Where was dragging the folder onto the app anywhere in my instructions lol? Try the instructions people actually tell you first

Just because I got used to dragging and dropping in every other app / site in desktop. Thought it too supports, but it didnt

Daeraxa, it may have been confusing due to language barrier. I suspect one here but regardless, that post didn't help here.

Shoban, glad you got it!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.