Homepage    |    GitHub    |    API    |    FAQ

Is there a way to sync and decrypt items manualy?

Is there a way to sync and decrypt items manually?

There is a problem with Joplin synchronization and decryption on Linux and Windows OS with slow hardware. I am using Dropbox, but as I remember, this problem persists in all cloud folders.

I noticed that in modern and fast hardware, syncing is working without problems. But in a slow environment, I constantly receive "Some items cannot be synchronized" error.

Is there any way to manually sync and decrypt items in a slow environment without destroying the target folder on Dropbox? Because I believe if I unpack the .jex file and sync it with Dropbox after that, there is a possibility that Dropbox will be wiped. I don't know anything about synchronization and how it works, so I am afraid to do something that can harm my database.

Is there any way to sync and decrypt items manually on a slow PC to avoid errors and sync it with the cloud folder (Dropbox or others) without wiping the cloud folder?


For bug reports, please post them on GitHub - Issues · laurent22/joplin · GitHub
If you post a bug report here, we cannot track it and there's a chance it won't be looked at and fixed.

For other support queries please indicate:

  • The version you are using. LATEST VERSION is not a version number!
    Joplin 1.7.11 (prod, linux)
    Client ID: b649eb6036044e07aa45f6e6c0a1d5a5
    Sync Version: 2
    Profile Version: 34
    Keychain Supported: No
    Revision: f560563 (master)
  • If it is a sync issue, please let us know what you are syncing with.
    Dropbox.
  • If you report a problem with upgrading, please let us know both versions (from/to).
  • If you report a problem with the editor, please tell us which editor you are using (WYSIWYG/Markdown).
  • The operating system you are using.
    Kernel: 5.4.0-70-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6
    wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal

If you can also please provide a log, as described here: https://joplinapp.org/debugging

This may not be what you're looking for but I would do as follows:

  • create a 2nd copy of your JEX file (all notes), just to be extra safe
  • uninstall Joplin from the desktop, manually delete the profile folder if necessary
  • manually remove the complete Joplin folder from your sync target (use a browser for this)
  • recreate an empty folder on the sync target
  • reinstall Joplin on your desktop, and import the JEX file
  • check notes to see you're happy with what you see
    IF desired
  • goto settings in Joplin and set up the sync target again (it's no longer there as we removed the profile folder !)
  • sync

Unless I misunderstood your description, that should do it. In any case, this way nothing can get lost ASSUMING that your JEX file was recent and complete.

1 Like

I have the same steps in my mind. But why I am hesitating...

I have Joplin on 4 mashines, two of them work without issues:

  • My fast laptop (on Linux or Windows - works on both OS)
  • My Android phone

But two constantly have "sync" or "decrypt" issues:

  • My slow 14-years old laptop (on Linux)
  • My slow virtual machine with 1 allocated processor and 8Gb RAM (on Windows)

As I have only one "fast" laptop, I need to share it with my family for consuming tasks and I struggle all the time I switch to Joplin on "slow" machines.

So I need to solve the problem on both "slow" machines while not destoying the "fast" ones. In your suggested solution I believe there are some risks to wipe setup on "fast" mashines and it solves problem only with one "slow" mashine.

I tried to find a way how to include additional machine in the existing environment, in other words.

I really hope there is a solution. Maybe some tricks with database timestamps to trick Dropbox and do not wipe it... It is so foggy for me.

Delete apps and profiles on 3 of the 4 machines, apply the same procedure explained before.

I have the same headache! Joplin fails the decrypt all the notes. Especially resources, e.g. Images.
And it has nothing to do with slow hardware. I run it on a 2017 Macbook pro with i7 and 16 GB RAM.

I know, it is strange, very strange. And this error we have only on desktops, I have never had it on phone.

It is not so simple. The second mashine whipes Dropbox for the first mashine.