Sync issue on File system Dropox folder

Hello,

I'm using Joplin for a year now, and I'm having a minor but annoying sync issue:

  • I'm syncing to my local dropbox folder (see settings below).
  • Joplin is always opened and running, on 2 PCs at least. PCs can go to sleed mode from time to time (but I'm pretty sure I've got this issue even when PC don't go to sleep).
  • Every 2 day or so, the automatic sync get stuck, the button show "Cancel" forever. If I click "Cancel", it write "Canceling..." but stay stuck forever as well.
  • I always have to close Joplin from the windows notification area, and reopen it, and voil├á it works!

It happened just today: earlier in the morning, I used Joplin, and I saw an automatic sync multiple time without issue. This noon, I even click manually on "Synchronise", and it worked too, no issue. I kept working on Joplin; and a few hours later, I noticed it was stuck.

Could it be that the process of Joplin is running for too long, so Windows (or Joplin itself) start to behave oddly?

It's probably not related to Dropbox, because for Joplin, I'm syncing to a local folder.
I did however some test when encountering the issue, closing/killing Dropbox process, reopen it, etc. No effect.


Sync settings are:

Target: File system
Directory: My Dropbox folder
Interval: 5 min


Joplin version is:

Joplin 2.7.15 (prod, win32)
Client ID: e993c6eef6aa456bba67a1ece9d87651
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes
Revision: 8352e23

(probably not the latest, but I tried half a dozen version during the year, and always got this issue)


PCs are running W10.

Thank you for reading!
Have a good day,

In fact, this has happened to me several times: Namely, whenever my laptop had no internet/wifi connection anymore, Joplin tries to synchronize and then apparently the sync process hangs itself in some form...I then could not solve this by reconnecting and "Cancel" did not work either, only a restart of the program helped.

I'm synching to Joplin-Server v2.7.4, so if it's the same issue, it has nothing to do with the sync target. PC also on Win10.

Joplin 2.8.4 (prod, win32)

Client-ID: 1a9cc84bc84042558ce8b84c8eafa947
Sync-Version: 3
Profil-Version: 41
Unterst├╝tzter Schl├╝sselbund: Ja

Revision: 889aecc

Best regards

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.